summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-11-08 10:22:50 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-11-08 10:22:50 +0000
commite1193bd0246f6a7522aea48a6e690eac458f196a (patch)
tree245ae5685cb05c12f6b3144741c35b4a8b3c2bed /dev-libs/botan
parentVersion bump. (diff)
downloadgentoo-2-e1193bd0246f6a7522aea48a6e690eac458f196a.tar.gz
gentoo-2-e1193bd0246f6a7522aea48a6e690eac458f196a.tar.bz2
gentoo-2-e1193bd0246f6a7522aea48a6e690eac458f196a.zip
version bump
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog7
-rw-r--r--dev-libs/botan/Manifest12
-rw-r--r--dev-libs/botan/botan-1.4.9.ebuild78
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.91
4 files changed, 87 insertions, 11 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index be3ada4fdcb9..8c478babc689 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.9 2005/10/18 20:27:10 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.10 2005/11/08 10:22:50 dragonheart Exp $
+
+*botan-1.4.9 (08 Nov 2005)
+
+ 08 Nov 2005; Daniel Black <dragonheart@gentoo.org> +botan-1.4.9.ebuild:
+ version bump
*botan-1.4.8 (18 Oct 2005)
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 45a3dd57b8a0..cadf1404a721 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f1b5bb7c6f4177ef13d4e79c59eca44b ChangeLog 1824
MD5 043543f19cd858215284f52640cd15ce botan-1.4.4.ebuild 2392
MD5 9084ddfdf04eb085ef50f6834f3cc744 botan-1.4.6.ebuild 2299
MD5 efd83cbf39ec97d23f820218adc29730 botan-1.4.7.ebuild 2468
MD5 ab92d300b5f64552f0c4666eb8954ad2 botan-1.4.8.ebuild 2447
+MD5 c5d968440efece20f201ddf05fe88b1d botan-1.4.9.ebuild 2465
MD5 2214700974b810ad0c871ae2110ff054 files/botan-1.4.4-gcc34.patch 479
MD5 010820c4ff5b87a3b62ea84bee465eed files/digest-botan-1.4.4 61
MD5 cdec8ad496751d2c376b3ccca0d8045d files/digest-botan-1.4.6 61
MD5 d834de2da4a478c4f9d25bff3f10b19b files/digest-botan-1.4.7 61
MD5 9e9606ac1332a12cce6e94364637ff19 files/digest-botan-1.4.8 61
+MD5 f35ec7d42986b3a8a270b4aaa7483817 files/digest-botan-1.4.9 61
MD5 d769a7ef93cd04ed5de9f468af0979cd metadata.xml 463
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFDVVq8mdTrptrqvGERArOrAJ44cAnVyId2NN5iFS5xEkDI3w8SlwCcDDCR
-R2i7u+ZTb2o3LknkflxDinE=
-=m9qN
------END PGP SIGNATURE-----
diff --git a/dev-libs/botan/botan-1.4.9.ebuild b/dev-libs/botan/botan-1.4.9.ebuild
new file mode 100644
index 000000000000..d823d670f182
--- /dev/null
+++ b/dev-libs/botan/botan-1.4.9.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.9.ebuild,v 1.1 2005/11/08 10:22:50 dragonheart Exp $
+
+# Comments/fixes to lloyd@randombit.net (author)
+
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/Botan-${PV}.tgz"
+
+KEYWORDS="~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl zlib"
+
+S="${WORKDIR}/Botan-${PV}"
+
+RDEPEND="virtual/libc
+ bzip2? ( >=app-arch/bzip2-1.0.1 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ gmp? ( >=dev-libs/gmp-4.1.2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )"
+
+# configure.pl requires DirHandle, Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
+
+ if useq bzip2; then modules="$modules,comp_bzip2"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
+ # removed?
+ #if useq qt; then modules="$modules,mux_qt"; fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+ if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
+
+ # should be enabled on mips64
+ if [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'amd64' -o \
+ "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64' -o "${PROFILE_ARCH}" = 'mips64' ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH='sparc32-v9'
+ else
+ CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+ fi
+
+ cd ${S}
+ einfo "Enabling modules: " ${modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX ${S}
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH=${S} ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
+}
diff --git a/dev-libs/botan/files/digest-botan-1.4.9 b/dev-libs/botan/files/digest-botan-1.4.9
new file mode 100644
index 000000000000..93b6bfbae4f0
--- /dev/null
+++ b/dev-libs/botan/files/digest-botan-1.4.9
@@ -0,0 +1 @@
+MD5 42acef0f6a0d70d4fb3871f15b49f32f Botan-1.4.9.tgz 1812447