summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-15 11:34:02 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-15 11:34:02 +0000
commit6e4142fdd7638c2450be864dee3f3b8ba67f9347 (patch)
tree96778e80c74dfa458e5249ed3b2f8dfe0b42e81d /dev-libs/btparser
parentVersion bump, drop old. (diff)
downloadgentoo-2-6e4142fdd7638c2450be864dee3f3b8ba67f9347.tar.gz
gentoo-2-6e4142fdd7638c2450be864dee3f3b8ba67f9347.tar.bz2
gentoo-2-6e4142fdd7638c2450be864dee3f3b8ba67f9347.zip
Version bump.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/btparser')
-rw-r--r--dev-libs/btparser/ChangeLog7
-rw-r--r--dev-libs/btparser/btparser-0.18.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-libs/btparser/ChangeLog b/dev-libs/btparser/ChangeLog
index 5d932cc4a1fe..4efbc5c372cf 100644
--- a/dev-libs/btparser/ChangeLog
+++ b/dev-libs/btparser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/btparser
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.7 2012/06/30 12:12:27 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/ChangeLog,v 1.8 2012/09/15 11:34:02 pacho Exp $
+
+*btparser-0.18 (15 Sep 2012)
+
+ 15 Sep 2012; Pacho Ramos <pacho@gentoo.org> +btparser-0.18.ebuild:
+ Version bump.
*btparser-0.17 (30 Jun 2012)
diff --git a/dev-libs/btparser/btparser-0.18.ebuild b/dev-libs/btparser/btparser-0.18.ebuild
new file mode 100644
index 000000000000..90653841dd36
--- /dev/null
+++ b/dev-libs/btparser/btparser-0.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/btparser/btparser-0.18.ebuild,v 1.1 2012/09/15 11:34:02 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+
+inherit python
+
+DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
+HOMEPAGE="https://fedorahosted.org/btparser/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/glib-2.21:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+}
+
+src_configure() {
+ # Configure checks for python.pc; our python-2.7 installs python-2.7.pc,
+ # while python-2.6 does not install any pkgconfig file.
+ export PYTHON_CFLAGS=$(python-config --includes)
+ export PYTHON_LIBS=$(python-config --libs)
+
+ econf \
+ $(use_enable static-libs static) \
+ --disable-maintainer-mode
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ python_mod_optimize btparser
+}
+
+pkg_postrm() {
+ python_mod_cleanup btparser
+}