summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-09-15 01:40:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-09-15 01:40:47 +0000
commitae0d4a7a606d4f447408504fa4fad15affb9dbdf (patch)
tree2bb38c4cbbf271e6e33721b38d282ed2a96486bc /dev-libs/confuse
parentVersion bumped, bug #237609. (diff)
downloadgentoo-2-ae0d4a7a606d4f447408504fa4fad15affb9dbdf.tar.gz
gentoo-2-ae0d4a7a606d4f447408504fa4fad15affb9dbdf.tar.bz2
gentoo-2-ae0d4a7a606d4f447408504fa4fad15affb9dbdf.zip
Fixed optimization issue, bug #236347.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-libs/confuse')
-rw-r--r--dev-libs/confuse/ChangeLog8
-rw-r--r--dev-libs/confuse/confuse-2.6-r2.ebuild42
-rw-r--r--dev-libs/confuse/files/confuse-2.6-O0.patch15
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/confuse/ChangeLog b/dev-libs/confuse/ChangeLog
index bdbdf2b00b05..c0fcb461ea1b 100644
--- a/dev-libs/confuse/ChangeLog
+++ b/dev-libs/confuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/confuse
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/ChangeLog,v 1.32 2008/05/17 03:07:07 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/ChangeLog,v 1.33 2008/09/15 01:40:47 matsuu Exp $
+
+*confuse-2.6-r2 (15 Sep 2008)
+
+ 15 Sep 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/confuse-2.6-O0.patch, +confuse-2.6-r2.ebuild:
+ Fixed optimization issue, bug #236347.
17 May 2008; MATSUU Takuto <matsuu@gentoo.org>
-files/confuse-2.5-libintl.patch, -files/confuse-2.5-maketest.patch,
diff --git a/dev-libs/confuse/confuse-2.6-r2.ebuild b/dev-libs/confuse/confuse-2.6-r2.ebuild
new file mode 100644
index 000000000000..ec066aaf2a04
--- /dev/null
+++ b/dev-libs/confuse/confuse-2.6-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/confuse-2.6-r2.ebuild,v 1.1 2008/09/15 01:40:47 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="a configuration file parser library"
+HOMEPAGE="http://www.nongnu.org/confuse/"
+SRC_URI="http://bzero.se/confuse/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="sys-devel/flex
+ sys-devel/libtool
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # bug #236347
+ epatch "${FILESDIR}"/${P}-O0.patch
+ # drop -Werror, bug #208095
+ sed -i -e 's/-Werror//' */Makefile.* || die
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ doman doc/man/man3/*.3
+ dodoc AUTHORS NEWS README
+ dohtml doc/html/* || die
+}
diff --git a/dev-libs/confuse/files/confuse-2.6-O0.patch b/dev-libs/confuse/files/confuse-2.6-O0.patch
new file mode 100644
index 000000000000..31b95fb2d53d
--- /dev/null
+++ b/dev-libs/confuse/files/confuse-2.6-O0.patch
@@ -0,0 +1,15 @@
+Index: src/confuse.c
+===================================================================
+RCS file: /sources/confuse/confuse/src/confuse.c,v
+retrieving revision 1.36
+diff -u -B -r1.36 confuse.c
+--- src/confuse.c 13 Oct 2007 20:01:45 -0000 1.36
++++ src/confuse.c 1 Sep 2008 11:57:30 -0000
+@@ -41,6 +41,7 @@
+ #define is_set(f, x) (((f) & (x)) == (f))
+
+ #if defined(ENABLE_NLS) && defined(HAVE_GETTEXT)
++# include <locale.h>
+ # include <libintl.h>
+ # define _(str) dgettext(PACKAGE, str)
+ #else