summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-27 16:20:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-27 16:20:36 +0000
commit70dea74d66e66e148030f377430554986663cdeb (patch)
tree7211680218d4903f583c2dd2a23a6b631f43492c /dev-libs/crypto++
parent2.6.32-r19: Linux patch 2.6.32.23. 2.6.35-r9: Linux patch 2.6.35.6 and remova... (diff)
downloadgentoo-2-70dea74d66e66e148030f377430554986663cdeb.tar.gz
gentoo-2-70dea74d66e66e148030f377430554986663cdeb.tar.bz2
gentoo-2-70dea74d66e66e148030f377430554986663cdeb.zip
Version bump.
(Portage version: 2.2_rc87_p23/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/ChangeLog8
-rw-r--r--dev-libs/crypto++/crypto++-5.6.1.ebuild52
-rw-r--r--dev-libs/crypto++/files/crypto++-5.6.1-fix_build_system.patch124
3 files changed, 183 insertions, 1 deletions
diff --git a/dev-libs/crypto++/ChangeLog b/dev-libs/crypto++/ChangeLog
index 4881443d3290..b40fe707c22f 100644
--- a/dev-libs/crypto++/ChangeLog
+++ b/dev-libs/crypto++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/crypto++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.58 2010/04/25 00:53:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/ChangeLog,v 1.59 2010/09/27 16:20:35 arfrever Exp $
+
+*crypto++-5.6.1 (27 Sep 2010)
+
+ 27 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +crypto++-5.6.1.ebuild, +files/crypto++-5.6.1-fix_build_system.patch:
+ Version bump.
25 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
crypto++-5.6.0-r1.ebuild:
diff --git a/dev-libs/crypto++/crypto++-5.6.1.ebuild b/dev-libs/crypto++/crypto++-5.6.1.ebuild
new file mode 100644
index 000000000000..a1f89c762513
--- /dev/null
+++ b/dev-libs/crypto++/crypto++-5.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.6.1.ebuild,v 1.1 2010/09/27 16:20:35 arfrever Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Crypto++ is a C++ class library of cryptographic schemes"
+HOMEPAGE="http://cryptopp.com"
+SRC_URI="mirror://sourceforge/cryptopp/cryptopp${PV//.}.zip"
+
+LICENSE="cryptopp"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_build_system.patch"
+}
+
+src_compile() {
+ # Higher optimizations cause problems.
+ replace-flags -O? -O1
+ filter-flags -fomit-frame-pointer
+ use amd64 && append-flags -DCRYPTOPP_DISABLE_ASM
+
+ emake -f GNUmakefile CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LIBDIR="$(get_libdir)" || die "emake failed"
+}
+
+src_test() {
+ # Ensure that all test vectors have Unix line endings.
+ local file
+ for file in TestVectors/*; do
+ edos2unix ${file}
+ done
+
+ if ! emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" test; then
+ eerror "Crypto++ self-tests failed."
+ eerror "Try to remove some optimization flags and reemerge Crypto++."
+ die "emake test failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install || die "emake install failed"
+}
diff --git a/dev-libs/crypto++/files/crypto++-5.6.1-fix_build_system.patch b/dev-libs/crypto++/files/crypto++-5.6.1-fix_build_system.patch
new file mode 100644
index 000000000000..829e9bf782cb
--- /dev/null
+++ b/dev-libs/crypto++/files/crypto++-5.6.1-fix_build_system.patch
@@ -0,0 +1,124 @@
+--- GNUmakefile
++++ GNUmakefile
+@@ -1,3 +1,5 @@
++LIBTOOL = libtool
++LIBDIR = lib
+ CXXFLAGS = -DNDEBUG -g -O2
+ #CXXFLAGS = -g
+ # -fPIC is supported. Please report any breakage of -fPIC as a bug.
+@@ -7,8 +9,9 @@
+ # LDFLAGS += -Wl,--gc-sections
+ ARFLAGS = -cr # ar needs the dash on OpenBSD
+ RANLIB = ranlib
+-CP = cp
++LN_S = ln -s
+ MKDIR = mkdir
++INSTALL = install
+ EGREP = egrep
+ UNAME = $(shell uname)
+ ISX86 = $(shell uname -m | $(EGREP) -c "i.86|x86|i86|amd64")
+@@ -120,46 +123,45 @@
+ SRCS = $(shell echo *.cpp)
+ endif
+
+-OBJS = $(SRCS:.cpp=.o)
+-# test.o needs to be after bench.o for cygwin 1.1.4 (possible ld bug?)
+-TESTOBJS = bench.o bench2.o test.o validat1.o validat2.o validat3.o adhoc.o datatest.o regtest.o fipsalgt.o dlltest.o
++OBJS = $(SRCS:.cpp=.lo)
++# test.lo needs to be after bench.lo for cygwin 1.1.4 (possible ld bug?)
++TESTOBJS = bench.lo bench2.lo test.lo validat1.lo validat2.lo validat3.lo adhoc.lo datatest.lo regtest.lo fipsalgt.lo dlltest.lo
+ LIBOBJS = $(filter-out $(TESTOBJS),$(OBJS))
+
+ DLLSRCS = algebra.cpp algparam.cpp asn.cpp basecode.cpp cbcmac.cpp channels.cpp cryptlib.cpp des.cpp dessp.cpp dh.cpp dll.cpp dsa.cpp ec2n.cpp eccrypto.cpp ecp.cpp eprecomp.cpp files.cpp filters.cpp fips140.cpp fipstest.cpp gf2n.cpp gfpcrypt.cpp hex.cpp hmac.cpp integer.cpp iterhash.cpp misc.cpp modes.cpp modexppc.cpp mqueue.cpp nbtheory.cpp oaep.cpp osrng.cpp pch.cpp pkcspad.cpp pubkey.cpp queue.cpp randpool.cpp rdtables.cpp rijndael.cpp rng.cpp rsa.cpp sha.cpp simple.cpp skipjack.cpp strciphr.cpp trdlocal.cpp
+-DLLOBJS = $(DLLSRCS:.cpp=.export.o)
+-LIBIMPORTOBJS = $(LIBOBJS:.o=.import.o)
+-TESTIMPORTOBJS = $(TESTOBJS:.o=.import.o)
+-DLLTESTOBJS = dlltest.dllonly.o
++DLLOBJS = $(DLLSRCS:.cpp=.export.lo)
++LIBIMPORTOBJS = $(LIBOBJS:.lo=.import.lo)
++TESTIMPORTOBJS = $(TESTOBJS:.lo=.import.lo)
++DLLTESTOBJS = dlltest.dllonly.lo
+
+-all: cryptest.exe
++all: libcrypto++.la
+
+-test: cryptest.exe
+- ./cryptest.exe v
++test: cryptest
++ ./cryptest v
+
+ clean:
+- $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
++ $(RM) -f .libs cryptest libcrypto++.* libcryptopp.* $(LIBOBJS) $(TESTOBJS) cryptopp.dll cryptest.import dlltest $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
+
+ install:
+- $(MKDIR) -p $(PREFIX)/include/cryptopp $(PREFIX)/lib $(PREFIX)/bin
+- $(CP) *.h $(PREFIX)/include/cryptopp
+- $(CP) *.a $(PREFIX)/lib
+- $(CP) *.so $(PREFIX)/lib
+- $(CP) *.exe $(PREFIX)/bin
++ $(MKDIR) -p $(DESTDIR)$(PREFIX)/include/crypto++ $(DESTDIR)$(PREFIX)/$(LIBDIR)
++ $(INSTALL) -m 644 *.h $(DESTDIR)$(PREFIX)/include/crypto++
++ $(LN_S) crypto++ $(DESTDIR)$(PREFIX)/include/cryptopp
++ $(LIBTOOL) --mode=install $(INSTALL) libcrypto++.la $(DESTDIR)$(PREFIX)/$(LIBDIR)
++ $(LN_S) libcrypto++.a $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.a
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so.0
++ $(LN_S) libcrypto++.so.0.0.0 $(DESTDIR)$(PREFIX)/$(LIBDIR)/libcryptopp.so.0.0.0
+
+-libcryptopp.a: $(LIBOBJS)
+- $(AR) $(ARFLAGS) $@ $(LIBOBJS)
+- $(RANLIB) $@
+-
+-libcryptopp.so: $(LIBOBJS)
+- $(CXX) -shared -o $@ $(LIBOBJS)
++libcrypto++.la: $(LIBOBJS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) $(LDFLAGS) -rpath $(PREFIX)/$(LIBDIR) -o $@ $(LIBOBJS)
+
+-cryptest.exe: libcryptopp.a $(TESTOBJS)
+- $(CXX) -o $@ $(CXXFLAGS) $(TESTOBJS) -L. -lcryptopp $(LDFLAGS) $(LDLIBS)
++cryptest: libcrypto++.la $(TESTOBJS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) $(LDFLAGS) -o $@ $(TESTOBJS) -L. -lcrypto++ $(LDLIBS)
+
+ nolib: $(OBJS) # makes it faster to test changes
+- $(CXX) -o ct $(CXXFLAGS) $(OBJS) $(LDFLAGS) $(LDLIBS)
++ $(LIBTOOL) --tag=CC --mode=link $(CXX) -o ct $(LDFLAGS) $(OBJS) $(LDLIBS)
+
+-dll: cryptest.import.exe dlltest.exe
++dll: cryptest.import dlltest
+
+ cryptopp.dll: $(DLLOBJS)
+ $(CXX) -shared -o $@ $(CXXFLAGS) $(DLLOBJS) $(LDFLAGS) $(LDLIBS) -Wl,--out-implib=libcryptopp.dll.a
+@@ -168,10 +170,10 @@
+ $(AR) $(ARFLAGS) $@ $(LIBIMPORTOBJS)
+ $(RANLIB) $@
+
+-cryptest.import.exe: cryptopp.dll libcryptopp.import.a $(TESTIMPORTOBJS)
++cryptest.import: cryptopp.dll libcryptopp.import.a $(TESTIMPORTOBJS)
+ $(CXX) -o $@ $(CXXFLAGS) $(TESTIMPORTOBJS) -L. -lcryptopp.dll -lcryptopp.import $(LDFLAGS) $(LDLIBS)
+
+-dlltest.exe: cryptopp.dll $(DLLTESTOBJS)
++dlltest: cryptopp.dll $(DLLTESTOBJS)
+ $(CXX) -o $@ $(CXXFLAGS) $(DLLTESTOBJS) -L. -lcryptopp.dll $(LDFLAGS) $(LDLIBS)
+
+ adhoc.cpp: adhoc.cpp.proto
+@@ -181,14 +183,14 @@
+ touch adhoc.cpp
+ endif
+
+-%.dllonly.o : %.cpp
++%.dllonly.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_DLL_ONLY -c $< -o $@
+
+-%.import.o : %.cpp
++%.import.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_IMPORTS -c $< -o $@
+
+-%.export.o : %.cpp
++%.export.lo : %.cpp
+ $(CXX) $(CXXFLAGS) -DCRYPTOPP_EXPORTS -c $< -o $@
+
+-%.o : %.cpp
+- $(CXX) $(CXXFLAGS) -c $<
++%.lo : %.cpp
++ $(LIBTOOL) --tag=CXX --mode=compile $(CXX) $(CXXFLAGS) -c $<