summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 18:25:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 18:25:34 +0000
commita1636d0900ac1cb0506c90975b6887df1d08660a (patch)
treedcb254e27f848a5e1665a5c427a2d7463c9294a5 /dev-libs/cyrus-imap-dev
parentKeyword ~x86-macos. (diff)
downloadgentoo-2-a1636d0900ac1cb0506c90975b6887df1d08660a.tar.gz
gentoo-2-a1636d0900ac1cb0506c90975b6887df1d08660a.tar.bz2
gentoo-2-a1636d0900ac1cb0506c90975b6887df1d08660a.zip
Add patch to build against berkdb 5.0 (same exact one as cyrus-imapd with same PV), bug #319933.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cyrus-imap-dev')
-rw-r--r--dev-libs/cyrus-imap-dev/ChangeLog9
-rw-r--r--dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild9
-rw-r--r--dev-libs/cyrus-imap-dev/files/cyrus-imapd-2.3.16+db-5.0.patch49
3 files changed, 60 insertions, 7 deletions
diff --git a/dev-libs/cyrus-imap-dev/ChangeLog b/dev-libs/cyrus-imap-dev/ChangeLog
index 4b9ad1fd8c37..5fc8a7ed0245 100644
--- a/dev-libs/cyrus-imap-dev/ChangeLog
+++ b/dev-libs/cyrus-imap-dev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/cyrus-imap-dev
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.63 2009/12/31 09:30:41 dertobi123 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/ChangeLog,v 1.64 2011/01/10 18:25:34 flameeyes Exp $
+
+ 10 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ cyrus-imap-dev-2.3.16.ebuild, +files/cyrus-imapd-2.3.16+db-5.0.patch:
+ Add patch to build against berkdb 5.0 (same exact one as cyrus-imapd with
+ same PV), bug #319933.
*cyrus-imap-dev-2.3.16 (31 Dec 2009)
diff --git a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild
index ebd46b43fcfe..63ae05f6ffb5 100644
--- a/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild
+++ b/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild,v 1.1 2009/12/31 09:30:41 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-imap-dev/cyrus-imap-dev-2.3.16.ebuild,v 1.2 2011/01/10 18:25:34 flameeyes Exp $
inherit eutils autotools
@@ -24,9 +24,6 @@ RDEPEND=">=sys-libs/db-3.2
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
DEPEND="${RDEPEND}
- sys-devel/libtool
- >=sys-devel/autoconf-2.58
- sys-devel/automake
>=sys-apps/sed-4"
S="${WORKDIR}/cyrus-imapd-${MY_PV}"
@@ -39,6 +36,8 @@ src_unpack() {
epatch "${FILESDIR}/cyrus-imapd-libwrap.patch" || die "patch failed"
fi
+ epatch "${FILESDIR}"/cyrus-imapd-2.3.16+db-5.0.patch
+
# Recreate configure.
export WANT_AUTOCONF="2.5"
eautoreconf
diff --git a/dev-libs/cyrus-imap-dev/files/cyrus-imapd-2.3.16+db-5.0.patch b/dev-libs/cyrus-imap-dev/files/cyrus-imapd-2.3.16+db-5.0.patch
new file mode 100644
index 000000000000..319abf1f6bb7
--- /dev/null
+++ b/dev-libs/cyrus-imap-dev/files/cyrus-imapd-2.3.16+db-5.0.patch
@@ -0,0 +1,49 @@
+Index: cyrus-imapd-2.3.16/lib/cyrusdb_berkeley.c
+===================================================================
+--- cyrus-imapd-2.3.16.orig/lib/cyrusdb_berkeley.c
++++ cyrus-imapd-2.3.16/lib/cyrusdb_berkeley.c
+@@ -108,7 +108,7 @@ static void db_panic(DB_ENV *dbenv __att
+ exit(EC_TEMPFAIL);
+ }
+
+-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
++#if ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)) || (DB_VERSION_MAJOR >= 5)
+ static void db_err(const DB_ENV *dbenv __attribute__((unused)),
+ const char *db_prfx, const char *buffer)
+ #else
+@@ -164,7 +164,7 @@ static int init(const char *dbdir, int m
+ #endif
+ }
+
+-#if (DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)
++#if ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 3)) || (DB_VERSION_MAJOR >= 5)
+ dbenv->set_msgcall(dbenv, db_msg);
+ #endif
+ dbenv->set_errcall(dbenv, db_err);
+@@ -282,7 +282,7 @@ static int mysync(void)
+
+ assert(dbinit);
+
+-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++#if !((DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5)
+ do {
+ #endif
+ #if (DB_VERSION_MAJOR > 3) || ((DB_VERSION_MAJOR == 3) && (DB_VERSION_MINOR > 0))
+@@ -290,7 +290,7 @@ static int mysync(void)
+ #else
+ r = txn_checkpoint(dbenv, 0, 0);
+ #endif
+-#if !(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1)
++#if !((DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || DB_VERSION_MAJOR >= 5)
+ } while (r == DB_INCOMPLETE); /* Never returned by BDB 4.1 */
+ #endif
+ if (r) {
+@@ -413,7 +413,7 @@ static int myopen(const char *fname, DBT
+ /* xxx set comparator! */
+ if (flags & CYRUSDB_MBOXSORT) db->set_bt_compare(db, mbox_compar);
+
+-#if DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1
++#if (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR >= 1) || (DB_VERSION_MAJOR >= 5)
+ r = (db->open)(db, NULL, fname, NULL, type, dbflags | DB_AUTO_COMMIT, 0664);
+ #else
+ r = (db->open)(db, fname, NULL, type, dbflags, 0664);