summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-08-10 20:39:31 +0000
committerTuan Van <langthang@gentoo.org>2004-08-10 20:39:31 +0000
commit80dbe21fcc59958e773fbe2453ee4b6970b5ad68 (patch)
tree1e085f1d0059adeb78fef1d5817ee61f461b25c4 /dev-libs/cyrus-sasl
parentRemoving obsolete versions (Manifest recommit) (diff)
downloadgentoo-2-80dbe21fcc59958e773fbe2453ee4b6970b5ad68.tar.gz
gentoo-2-80dbe21fcc59958e773fbe2453ee4b6970b5ad68.tar.bz2
gentoo-2-80dbe21fcc59958e773fbe2453ee4b6970b5ad68.zip
add --without-des if ! use ssl. Resolve bug #59634.
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog6
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild7
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild15
3 files changed, 21 insertions, 7 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 4f7e50fc1536..e59911db7757 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.89 2004/07/26 16:27:25 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.90 2004/08/10 20:39:31 langthang Exp $
+
+ 10 Aug 2004; Tuan Van <langthang@gentoo.org> cyrus-sasl-2.1.18-r2.ebuild,
+ cyrus-sasl-2.1.19.ebuild:
+ add --without-des if ! use ssl. Resolve bug #59634.
26 Jul 2004; Tuan Van <langthang@gentoo.org> cyrus-sasl-2.1.19.ebuild:
default to gdbm for SASLdb database backend if both berkdb and gdbm in
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild
index 3ae01a0345e4..abf16b1512d0 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild,v 1.4 2004/08/02 11:42:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.18-r2.ebuild,v 1.5 2004/08/10 20:39:31 langthang Exp $
inherit eutils flag-o-matic gnuconfig
@@ -87,6 +87,11 @@ src_compile() {
myconf="${myconf} `use_with postgres pgsql` `use_enable postgres sql`"
myconf="${myconf} `use_enable java` `use_with java javahome ${JAVA_HOME}`"
+ # fix for bug #59634. langthang 20040810.
+ if ! use ssl; then
+ myconf="${myconf} --without-des"
+ fi
+
if use mysql || use postgres ; then
myconf="${myconf} --enable-sql"
else
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild
index 9fb1cf0c251a..ca66df54c848 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild,v 1.3 2004/07/26 16:27:25 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.19.ebuild,v 1.4 2004/08/10 20:39:31 langthang Exp $
inherit eutils flag-o-matic gnuconfig
@@ -44,9 +44,9 @@ pkg_setup() {
einfo "to build cyrus-sasl with Berkeley database as your SASLdb backend."
)
echo
- ewarn "Waiting 30 seconds before starting..."
+ ewarn "Waiting 10 seconds before starting..."
ewarn "(Control-C to abort)..."
- sleep 30
+ sleep 10
fi
echo
@@ -58,8 +58,8 @@ pkg_setup() {
einfo "SASLAUTHD_OPTS=\"\${SASLAUTH_MECH} -a pam -r\""
einfo "Don't forget to restart the service: \`/etc/init.d/saslauthd restart\`."
echo
- einfo "Pause 30 seconds before continuing."
- sleep 30
+ einfo "Pause 10 seconds before continuing."
+ sleep 10
}
src_unpack() {
@@ -108,6 +108,11 @@ src_compile() {
myconf="${myconf} `use_with postgres pgsql` `use_enable postgres sql`"
myconf="${myconf} `use_enable java` `use_with java javahome ${JAVA_HOME}`"
+ # fix for bug #59634. langthang 20040810.
+ if ! use ssl; then
+ myconf="${myconf} --without-des"
+ fi
+
if use mysql || use postgres ; then
myconf="${myconf} --enable-sql"
else