summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-25 02:24:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-25 02:24:50 +0000
commit3e5abc7efd4abe261f299f0f14f33f5078c09294 (patch)
treea4c1a89d74e55bc6bf1fabab58a8e6a35c65b5ce /dev-libs/dietlibc
parentStable on sparc wrt bug #50857. (Manifest recommit) (diff)
downloadgentoo-2-3e5abc7efd4abe261f299f0f14f33f5078c09294.tar.gz
gentoo-2-3e5abc7efd4abe261f299f0f14f33f5078c09294.tar.bz2
gentoo-2-3e5abc7efd4abe261f299f0f14f33f5078c09294.zip
arm KEYWORD
Diffstat (limited to 'dev-libs/dietlibc')
-rw-r--r--dev-libs/dietlibc/dietlibc-0.24.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/dev-libs/dietlibc/dietlibc-0.24.ebuild b/dev-libs/dietlibc/dietlibc-0.24.ebuild
index 5d06f067a90f..1700bb3a115d 100644
--- a/dev-libs/dietlibc/dietlibc-0.24.ebuild
+++ b/dev-libs/dietlibc/dietlibc-0.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.24.ebuild,v 1.8 2004/03/25 21:39:12 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.24.ebuild,v 1.9 2004/05/25 02:24:50 vapier Exp $
inherit eutils flag-o-matic fixheadtails gcc
@@ -8,22 +8,22 @@ DESCRIPTION="A minimal libc"
HOMEPAGE="http://www.fefe.de/dietlibc/"
SRC_URI="mirror://kernel/linux/libs/${PN}/${P}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~sparc ~hppa ~amd64 ~alpha ~ppc"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha arm ~hppa ~amd64"
IUSE=""
DEPEND=">=sys-apps/sed-4"
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd ${S}
epatch "${FILESDIR}/${PV}-dirent-prototype.patch"
[ $(gcc-major-version) -eq 3 ] && epatch "${FILESDIR}/gcc-33.patch"
# depending on glibc to provide guard symbols, does not work with -nostdlib building
- filter-flags "-fstack-protector"
- filter-flags "fstack-protector-all"
+ filter-flags -fstack-protector -fstack-protector-all
# Fix for 45716
replace-sparc64-flags
@@ -31,8 +31,9 @@ src_unpack() {
sed -i \
-e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
-e "s:^prefix.*:prefix=/usr/diet:" \
- -e "s:^#DESTDIR=.*:DESTDIR=${D}:" Makefile || \
- die "sed Makefile failed"
+ -e "s:^#DESTDIR=.*:DESTDIR=${D}:" \
+ Makefile \
+ || die "sed Makefile failed"
# New fix for sparc64 and dietlibc, fixes bug #45601
[ "${PROFILE_ARCH}" = "sparc64" ] && \
@@ -42,8 +43,6 @@ src_unpack() {
}
src_compile() {
- filter-flags "-fstack-protector"
-
emake || die "emake failed"
}
@@ -53,7 +52,6 @@ src_install() {
exeinto /usr/bin
newexe bin-$(uname -m | sed -e 's/i[4-9]86/i386/' -e 's/armv[3-6][lb]/arm/' -e 's/sparc64/sparc/')/diet-i diet || die "newexe failed"
- doman diet.1 || die "doman failed"
- dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING || \
- die "dodoc failed"
+ doman diet.1
+ dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING
}