summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-12-11 06:41:09 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-12-11 06:41:09 +0000
commit6dfa4fced2ecaa766fd3a3f2f725fc737fe4cbfc (patch)
tree3389bcd3659de30b3d416119d7faa2a0f8cb1f41 /dev-libs/elfutils
parentVersion bump. Adds support for copying over extended attributes such as (diff)
downloadgentoo-2-6dfa4fced2ecaa766fd3a3f2f725fc737fe4cbfc.tar.gz
gentoo-2-6dfa4fced2ecaa766fd3a3f2f725fc737fe4cbfc.tar.bz2
gentoo-2-6dfa4fced2ecaa766fd3a3f2f725fc737fe4cbfc.zip
Version bump.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog8
-rw-r--r--dev-libs/elfutils/elfutils-0.150.ebuild60
-rw-r--r--dev-libs/elfutils/files/elfutils-0.150-bashifications.patch23
3 files changed, 90 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 948c672e5086..3bfab2d846ff 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.142 2010/09/19 09:02:53 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.143 2010/12/11 06:41:09 dirtyepic Exp $
+
+*elfutils-0.150 (11 Dec 2010)
+
+ 11 Dec 2010; Ryan Hill <dirtyepic@gentoo.org> +elfutils-0.150.ebuild,
+ +files/elfutils-0.150-bashifications.patch:
+ Version bump.
*elfutils-0.149 (19 Sep 2010)
diff --git a/dev-libs/elfutils/elfutils-0.150.ebuild b/dev-libs/elfutils/elfutils-0.150.ebuild
new file mode 100644
index 000000000000..60739c446064
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.150.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.150.ebuild,v 1.1 2010/12/11 06:41:09 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="https://fedorahosted.org/elfutils"
+SRC_URI="https://fedorahosted.org/releases/e/l/elfutils/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls zlib elibc_glibc"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( !prefix? ( >=sys-libs/glibc-2.7 ) )
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-4.1.2
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.150-bashifications.patch #287130
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ LC_ALL="C" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}
diff --git a/dev-libs/elfutils/files/elfutils-0.150-bashifications.patch b/dev-libs/elfutils/files/elfutils-0.150-bashifications.patch
new file mode 100644
index 000000000000..a2f2b858574d
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.150-bashifications.patch
@@ -0,0 +1,23 @@
+Remove bashifications
+https://bugs.gentoo.org/287130
+
+--- a/configure
++++ b/configure
+@@ -4880,7 +4880,7 @@ ac_config_files="$ac_config_files version.h:config/version.h.in"
+
+ # 1.234<whatever> -> 1234<whatever>
+ case "$PACKAGE_VERSION" in
+-[0-9].*) eu_version="${PACKAGE_VERSION/./}" ;;
++[0-9].*) eu_version=`echo "$PACKAGE_VERSION" | sed 's@\.@@'` ;;
+ *) as_fn_error $? "confused by version number '$PACKAGE_VERSION'" "$LINENO" 5 ;;
+ esac
+ case "$eu_version" in
+@@ -4909,7 +4909,7 @@ case "$eu_version" in
+ esac
+
+ # Round up to the next release API (x.y) version.
+-eu_version=$[($eu_version + 999) / 1000]
++eu_version=`expr \( $eu_version + 999 \) / 1000`
+
+ cat >confcache <<\_ACEOF
+ # This file is a shell script that caches the results of configure