summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-28 11:42:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-28 11:42:42 +0000
commite008bffbcc139ab03fd8394138fc6168f7f0c686 (patch)
tree782ed145d753633b1ffd0c35d4b47612eb85f9ef /dev-libs/expat/expat-2.1.0.ebuild
parentinitial import, based on Olivier Huber work in bug #350056 and then converted... (diff)
downloadgentoo-2-e008bffbcc139ab03fd8394138fc6168f7f0c686.tar.gz
gentoo-2-e008bffbcc139ab03fd8394138fc6168f7f0c686.tar.bz2
gentoo-2-e008bffbcc139ab03fd8394138fc6168f7f0c686.zip
Version bump.
(Portage version: 2.2.0_alpha92/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/expat/expat-2.1.0.ebuild')
-rw-r--r--dev-libs/expat/expat-2.1.0.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/expat/expat-2.1.0.ebuild b/dev-libs/expat/expat-2.1.0.ebuild
new file mode 100644
index 000000000000..a362d357224f
--- /dev/null
+++ b/dev-libs/expat/expat-2.1.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/expat/expat-2.1.0.ebuild,v 1.1 2012/03/28 11:42:42 ssuominen Exp $
+
+EAPI=4
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="XML parsing libraries"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="elibc_FreeBSD examples static-libs unicode"
+
+src_prepare() {
+ elibtoolize
+ epunt_cxx
+
+ mkdir "${S}"-build{,u,w} || die
+}
+
+src_configure() {
+ local myconf="$(use_enable static-libs static)"
+
+ pushd "${S}"-build >/dev/null
+ ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ CFLAGS="${CFLAGS} -fshort-wchar" CPPFLAGS="${CPPFLAGS} -DXML_UNICODE_WCHAR_T" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ pushd "${S}"-build >/dev/null
+ emake
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake buildlib LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake buildlib LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ dodoc Changes README
+ dohtml doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ pushd "${S}"-build >/dev/null
+ emake install DESTDIR="${D}"
+ popd >/dev/null
+
+ if use unicode; then
+ pushd "${S}"-buildu >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatu.la
+ popd >/dev/null
+
+ pushd "${S}"-buildw >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+
+ rm -f "${ED}"usr/lib*/libexpat{,u,w}.la
+
+ # libgeom in /lib and ifconfig in /sbin require it on FreeBSD since we
+ # stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
+ use elibc_FreeBSD && gen_usr_ldscript -a expat{,u,w}
+}