summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 15:44:57 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 15:44:57 +0000
commit67199db6e5cb9cb2d4c550ce89f259ec8e226944 (patch)
tree8928b262dfe22d4f2def556ceb56fb8a61957c7f /dev-libs/gdl/gdl-3.10.0.ebuild
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-67199db6e5cb9cb2d4c550ce89f259ec8e226944.tar.gz
gentoo-2-67199db6e5cb9cb2d4c550ce89f259ec8e226944.tar.bz2
gentoo-2-67199db6e5cb9cb2d4c550ce89f259ec8e226944.zip
Version bump for Gnome 3.10, drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/gdl/gdl-3.10.0.ebuild')
-rw-r--r--dev-libs/gdl/gdl-3.10.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/gdl/gdl-3.10.0.ebuild b/dev-libs/gdl/gdl-3.10.0.ebuild
new file mode 100644
index 000000000000..1e65b6de945b
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gdl/gdl-3.10.0.ebuild,v 1.1 2013/12/24 15:44:57 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://developer.gnome.org/gdl/"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure $(use_enable introspection)
+}