summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-07-24 21:43:27 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-07-24 21:43:27 +0000
commit85835c5c3f9cbdc2201e3ca2d6a2673ad4e56d05 (patch)
tree98fb22a309fb86b6f64a23023dfd896ff410e2b2 /dev-libs/geoip/geoip-1.3.12.ebuild
parentVersion bump, bug #100143. (diff)
downloadgentoo-2-85835c5c3f9cbdc2201e3ca2d6a2673ad4e56d05.tar.gz
gentoo-2-85835c5c3f9cbdc2201e3ca2d6a2673ad4e56d05.tar.bz2
gentoo-2-85835c5c3f9cbdc2201e3ca2d6a2673ad4e56d05.zip
1.3.12 version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/geoip/geoip-1.3.12.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.3.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.3.12.ebuild b/dev-libs/geoip/geoip-1.3.12.ebuild
new file mode 100644
index 000000000000..1ee256f0c109
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.3.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.3.12.ebuild,v 1.1 2005/07/24 21:43:27 vanquirius Exp $
+
+MY_P=${P/geoip/GeoIP}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-libs/zlib"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}