summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-10 22:46:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-10 22:46:32 +0000
commit219b40fdced2a92a507e7fd2fb522ed3b57c05a8 (patch)
treeacefa4675799bb46bb9c10f40d63cd4168edab4d /dev-libs/gf2x/gf2x-0.9.5.ebuild
parentversion bump (diff)
downloadgentoo-2-219b40fdced2a92a507e7fd2fb522ed3b57c05a8.tar.gz
gentoo-2-219b40fdced2a92a507e7fd2fb522ed3b57c05a8.tar.bz2
gentoo-2-219b40fdced2a92a507e7fd2fb522ed3b57c05a8.zip
Version bump, using real packaging system
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/gf2x/gf2x-0.9.5.ebuild')
-rw-r--r--dev-libs/gf2x/gf2x-0.9.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/gf2x/gf2x-0.9.5.ebuild b/dev-libs/gf2x/gf2x-0.9.5.ebuild
new file mode 100644
index 000000000000..b71daa709b73
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-0.9.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gf2x/gf2x-0.9.5.ebuild,v 1.1 2009/08/10 22:46:32 bicatali Exp $
+
+EAPI=2
+
+PID=22129 # hack
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="http://gf2x.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/${PID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="sse2"
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable sse2) ABI=default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README AUTHORS BUGS
+}