summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:50:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 16:50:26 +0000
commit806729b343786afaba725cef1822f87de7df1ee5 (patch)
treeb45263461dd8690e8050526476f72ea96de8d22d /dev-libs/glib
parentAdded LICENSE, SLOT, KEYWORDS (diff)
downloadgentoo-2-806729b343786afaba725cef1822f87de7df1ee5.tar.gz
gentoo-2-806729b343786afaba725cef1822f87de7df1ee5.tar.bz2
gentoo-2-806729b343786afaba725cef1822f87de7df1ee5.zip
repoman'd
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/files/digest-glib-2.0.1-r61
-rw-r--r--dev-libs/glib/files/digest-glib-2.0.31
-rw-r--r--dev-libs/glib/files/digest-glib-2.0.41
-rw-r--r--dev-libs/glib/glib-1.2.10-r4.ebuild24
-rw-r--r--dev-libs/glib/glib-2.0.1-r6.ebuild66
-rw-r--r--dev-libs/glib/glib-2.0.3.ebuild65
-rw-r--r--dev-libs/glib/glib-2.0.4-r1.ebuild33
-rw-r--r--dev-libs/glib/glib-2.0.4.ebuild56
8 files changed, 20 insertions, 227 deletions
diff --git a/dev-libs/glib/files/digest-glib-2.0.1-r6 b/dev-libs/glib/files/digest-glib-2.0.1-r6
deleted file mode 100644
index 7cceb72b2250..000000000000
--- a/dev-libs/glib/files/digest-glib-2.0.1-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d81814a57f3861c3077e55870faabede glib-2.0.1.tar.bz2 1409749
diff --git a/dev-libs/glib/files/digest-glib-2.0.3 b/dev-libs/glib/files/digest-glib-2.0.3
deleted file mode 100644
index 588434a5bd9d..000000000000
--- a/dev-libs/glib/files/digest-glib-2.0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cba4ea14c4969c24dc49f08469aa0d7d glib-2.0.3.tar.bz2 1455505
diff --git a/dev-libs/glib/files/digest-glib-2.0.4 b/dev-libs/glib/files/digest-glib-2.0.4
deleted file mode 100644
index b1a2f8a20d38..000000000000
--- a/dev-libs/glib/files/digest-glib-2.0.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a4101c1f3fc1306eeb8f048f08e3f4b1 glib-2.0.4.tar.bz2 1463890
diff --git a/dev-libs/glib/glib-1.2.10-r4.ebuild b/dev-libs/glib/glib-1.2.10-r4.ebuild
index 6ccf83d0dccc..fa590f753369 100644
--- a/dev-libs/glib/glib-1.2.10-r4.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r4.ebuild
@@ -1,36 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r4.ebuild,v 1.3 2002/07/24 03:44:56 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r4.ebuild,v 1.4 2002/08/01 16:50:26 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${P}.tar.gz
ftp://ftp.gnome.org/pub/GNOME/stable/sources/glib/${P}.tar.gz"
HOMEPAGE="http://www.gtk.org/"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
KEYWORDS="x86 ppc"
+
DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc"
-LICENSE="LGPL-2.1"
-SLOT="1"
src_compile() {
- local myconf
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-threads=posix \
- --enable-debug=yes || die
+ econf \
+ --with-threads=posix \
+ --enable-debug=yes || die
emake || die
}
src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
+ einstall || die
( cd ${D}/usr/lib ; chmod 755 libgmodule-1.2.so.* )
diff --git a/dev-libs/glib/glib-2.0.1-r6.ebuild b/dev-libs/glib/glib-2.0.1-r6.ebuild
deleted file mode 100644
index ecc7b1d25e28..000000000000
--- a/dev-libs/glib/glib-2.0.1-r6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.1-r6.ebuild,v 1.3 2002/07/24 03:44:56 cselkirk Exp $
-
-# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
-DEBUG="yes"
-RESTRICT="nostrip"
-# force debug information
-CFLAGS="${CFLAGS} -g"
-CXXFLAGS="${CXXFLAGS} -g"
-
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The GLib library of C routines"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
-HOMEPAGE="http://www.gtk.org/"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ppc"
-SLOT="2"
-
-DEPEND="virtual/glibc
- >=dev-util/pkgconfig-0.12.0
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-
-# libiconv breaks other stuff
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
-# Running libtoolize results in missing .so files -- karltk 2002-05-25
-# libtoolize --copy --force
- local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-threads=posix \
- ${myconf} \
- --enable-debug=yes || die
-
-# This had to be removed since it broke other stuff. darn. 2002-05-03
-# --with-libiconv=gnu \
-
-
-# you cannot disable debug or this will fail building.
-# odd but true :/
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
-}
-
-
-
-
-
diff --git a/dev-libs/glib/glib-2.0.3.ebuild b/dev-libs/glib/glib-2.0.3.ebuild
deleted file mode 100644
index ec5b6491512f..000000000000
--- a/dev-libs/glib/glib-2.0.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.3.ebuild,v 1.2 2002/07/11 06:30:20 drobbins Exp $
-
-# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
-DEBUG="yes"
-RESTRICT="nostrip"
-# force debug information
-CFLAGS="${CFLAGS} -g"
-CXXFLAGS="${CXXFLAGS} -g"
-
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The GLib library of C routines"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
-HOMEPAGE="http://www.gtk.org/"
-LICENSE="LGPL-2.1"
-SLOT="2"
-
-DEPEND="virtual/glibc
- >=dev-util/pkgconfig-0.12.0
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-
-# libiconv breaks other stuff
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
-# Running libtoolize results in missing .so files -- karltk 2002-05-25
-# libtoolize --copy --force
- local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-threads=posix \
- ${myconf} \
- --enable-debug=yes || die
-
-# This had to be removed since it broke other stuff. darn. 2002-05-03
-# --with-libiconv=gnu \
-
-
-# you cannot disable debug or this will fail building.
-# odd but true :/
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
-}
-
-
-
-
-
diff --git a/dev-libs/glib/glib-2.0.4-r1.ebuild b/dev-libs/glib/glib-2.0.4-r1.ebuild
index 94d85da189f3..f58b7d36f20c 100644
--- a/dev-libs/glib/glib-2.0.4-r1.ebuild
+++ b/dev-libs/glib/glib-2.0.4-r1.ebuild
@@ -1,21 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.4-r1.ebuild,v 1.3 2002/07/24 03:44:56 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.4-r1.ebuild,v 1.4 2002/08/01 16:50:26 seemant Exp $
inherit debug
inherit libtool
-
S=${WORKDIR}/${P}
DESCRIPTION="The GLib library of C routines"
SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
HOMEPAGE="http://www.gtk.org/"
+
+SLOT="2"
LICENSE="LGPL-2.1"
KEYWORDS="x86 ppc"
-SLOT="2"
-DEPEND="virtual/glibc
- >=dev-util/pkgconfig-0.12.0
+DEPEND=">=dev-util/pkgconfig-0.12.0
doc? ( >=dev-util/gtk-doc-0.9-r2 )"
@@ -31,30 +30,20 @@ src_compile() {
local myconf=""
use doc && myconf="${myconf} --enable-gtk-doc"
use doc || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
+
+ econf \
--with-threads=posix \
- ${myconf} \
- --enable-debug=yes || die
+ --enable-debug=yes \
+ ${myconf} || die
-# you cannot disable debug or this will fail building.
-# odd but true :/
+ # you cannot disable debug or this will fail building.
+ # odd but true :/
emake || die
}
src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
+ einstall || die
dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
}
-
-
-
-
-
diff --git a/dev-libs/glib/glib-2.0.4.ebuild b/dev-libs/glib/glib-2.0.4.ebuild
deleted file mode 100644
index 6f650c9dae49..000000000000
--- a/dev-libs/glib/glib-2.0.4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.0.4.ebuild,v 1.3 2002/07/24 03:44:56 cselkirk Exp $
-
-inherit debug
-inherit libtool
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The GLib library of C routines"
-SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
-HOMEPAGE="http://www.gtk.org/"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ppc"
-SLOT="2"
-
-DEPEND="virtual/glibc
- >=dev-util/pkgconfig-0.12.0
- doc? ( >=dev-util/gtk-doc-0.9-r2 )"
-
-
-# libiconv breaks other stuff
-
-RDEPEND="virtual/glibc"
-
-src_compile() {
- elibtoolize
- local myconf
- use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-threads=posix \
- ${myconf} \
- --enable-debug=yes || die
-
-# you cannot disable debug or this will fail building.
-# odd but true :/
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- install || die
-
- dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
-}
-
-
-
-
-