summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-11 20:44:17 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-11 20:44:17 +0000
commitb2e7ecd9569c998578b6ffcb8830875367e37166 (patch)
treee5998a164d1c0ca68e026de414a1baad05c732fb /dev-libs/glib
parentMarking rkhunter-1.3.8 ppc for bug 382453 (diff)
downloadgentoo-2-b2e7ecd9569c998578b6ffcb8830875367e37166.tar.gz
gentoo-2-b2e7ecd9569c998578b6ffcb8830875367e37166.tar.bz2
gentoo-2-b2e7ecd9569c998578b6ffcb8830875367e37166.zip
Assume pkgconfig exists in cross-compile setups since we need to execute `pkg-config` from ROOT=/ and not the cross-one from .
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog7
-rw-r--r--dev-libs/glib/glib-2.30.2-r1.ebuild10
-rw-r--r--dev-libs/glib/glib-2.30.2.ebuild12
3 files changed, 19 insertions, 10 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index a6a61a1c564f..11c15b6a6b44 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.497 2012/01/10 21:25:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.498 2012/01/11 20:44:17 vapier Exp $
+
+ 11 Jan 2012; Mike Frysinger <vapier@gentoo.org> glib-2.30.2.ebuild,
+ glib-2.30.2-r1.ebuild:
+ Assume pkgconfig exists in cross-compile setups since we need to execute
+ `pkg-config` from ROOT=/ and not the cross-one from .
*glib-2.30.2-r1 (10 Jan 2012)
diff --git a/dev-libs/glib/glib-2.30.2-r1.ebuild b/dev-libs/glib/glib-2.30.2-r1.ebuild
index f70765eb20b1..0971af126752 100644
--- a/dev-libs/glib/glib-2.30.2-r1.ebuild
+++ b/dev-libs/glib/glib-2.30.2-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.30.2-r1.ebuild,v 1.1 2012/01/10 21:25:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.30.2-r1.ebuild,v 1.2 2012/01/11 20:44:17 vapier Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
# Avoid runtime dependency on python when USE=test
-inherit autotools gnome.org libtool eutils flag-o-matic multilib pax-utils python virtualx
+inherit autotools gnome.org libtool eutils flag-o-matic multilib pax-utils python toolchain-funcs virtualx
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -132,8 +132,10 @@ src_prepare() {
}
src_configure() {
- # Avoid circular depend with dev-util/pkgconfig
- if ! has_version dev-util/pkgconfig; then
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! has_version dev-util/pkgconfig; then
if has_version sys-apps/dbus; then
export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
export DBUS1_LIBS="-ldbus-1"
diff --git a/dev-libs/glib/glib-2.30.2.ebuild b/dev-libs/glib/glib-2.30.2.ebuild
index dba2984f1894..b0832289156a 100644
--- a/dev-libs/glib/glib-2.30.2.ebuild
+++ b/dev-libs/glib/glib-2.30.2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.30.2.ebuild,v 1.5 2011/12/31 21:26:59 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.30.2.ebuild,v 1.6 2012/01/11 20:44:17 vapier Exp $
EAPI="4"
PYTHON_DEPEND="utils? 2"
# Avoid runtime dependency on python when USE=test
-inherit autotools gnome.org libtool eutils flag-o-matic multilib pax-utils python virtualx
+inherit autotools gnome.org libtool eutils flag-o-matic multilib pax-utils python toolchain-funcs virtualx
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -129,8 +129,10 @@ src_prepare() {
}
src_configure() {
- # Avoid circular depend with dev-util/pkgconfig
- if ! has_version dev-util/pkgconfig; then
+ # Avoid circular depend with dev-util/pkgconfig and
+ # native builds (cross-compiles won't need pkg-config
+ # in the target ROOT to work here)
+ if ! tc-is-cross-compiler && ! has_version dev-util/pkgconfig; then
if has_version sys-apps/dbus; then
export DBUS1_CFLAGS="-I/usr/include/dbus-1.0 -I/usr/$(get_libdir)/dbus-1.0/include"
export DBUS1_LIBS="-ldbus-1"