summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2004-09-29 04:22:39 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2004-09-29 04:22:39 +0000
commitd066296300cd90296d6629c9b235197c3f64defa (patch)
treee17b2783808b448e7264b8e203c5f2534236f30d /dev-libs/glib
parentFix for bug #60247 is needed again, I'll submit a proper fix upstream later. ... (diff)
downloadgentoo-2-d066296300cd90296d6629c9b235197c3f64defa.tar.gz
gentoo-2-d066296300cd90296d6629c9b235197c3f64defa.tar.bz2
gentoo-2-d066296300cd90296d6629c9b235197c3f64defa.zip
Updated to not install charset.alias on macos.
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/ChangeLog5
-rw-r--r--dev-libs/glib/glib-2.4.4.ebuild8
-rw-r--r--dev-libs/glib/glib-2.4.5.ebuild8
-rw-r--r--dev-libs/glib/glib-2.4.6.ebuild8
4 files changed, 25 insertions, 4 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index 3ae04f9b3d03..f1f0788123d1 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/glib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.96 2004/09/19 07:49:52 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.97 2004/09/29 04:22:39 j4rg0n Exp $
+
+ 29 Sep 2004; Lina Pezzella <j4rg0n@gentoo.org> glib-2.4.4.ebuild, glib-2.4.5.ebuild, glib-2.4.6.ebuild:
+ Updated to not install charset.alias on macos.
19 Sep 2004; Joshua Kinard <kumba@gentoo.org> glib-2.4.5.ebuild:
Marked stable on mips.
diff --git a/dev-libs/glib/glib-2.4.4.ebuild b/dev-libs/glib/glib-2.4.4.ebuild
index c41ee9302e53..c0f564f8e906 100644
--- a/dev-libs/glib/glib-2.4.4.ebuild
+++ b/dev-libs/glib/glib-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.10 2004/09/16 01:49:52 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.4.ebuild,v 1.11 2004/09/29 04:22:39 j4rg0n Exp $
inherit libtool
@@ -43,6 +43,12 @@ src_install() {
# einstall || die
make DESTDIR=${D} install || die
+ # Do not install charset.alias for ppc-macos since it already exists.
+ if (use macos || use ppc-macos); then
+ einfo "Not installing charset.alias on macos"
+ rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
+ fi
+
# Consider invalid UTF-8 filenames as locale-specific.
# FIXME : we should probably move to suggesting G_FILENAME_ENC
dodir /etc/env.d
diff --git a/dev-libs/glib/glib-2.4.5.ebuild b/dev-libs/glib/glib-2.4.5.ebuild
index d70a68ff6805..aaac9341465e 100644
--- a/dev-libs/glib/glib-2.4.5.ebuild
+++ b/dev-libs/glib/glib-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.10 2004/09/24 13:08:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.5.ebuild,v 1.11 2004/09/29 04:22:39 j4rg0n Exp $
inherit libtool
@@ -39,6 +39,12 @@ src_install() {
# einstall || die
make DESTDIR=${D} install || die
+ # Do not install charset.alias for ppc-macos since it already exists.
+ if (use macos || use ppc-macos); then
+ einfo "Not installing charset.alias on macos"
+ rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
+ fi
+
# Consider invalid UTF-8 filenames as locale-specific.
# FIXME : we should probably move to suggesting G_FILENAME_ENC
dodir /etc/env.d
diff --git a/dev-libs/glib/glib-2.4.6.ebuild b/dev-libs/glib/glib-2.4.6.ebuild
index 6f38ccadffab..f42f3eecd4fe 100644
--- a/dev-libs/glib/glib-2.4.6.ebuild
+++ b/dev-libs/glib/glib-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.4 2004/09/24 13:08:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.4.6.ebuild,v 1.5 2004/09/29 04:22:39 j4rg0n Exp $
inherit libtool
@@ -42,6 +42,12 @@ src_install() {
# einstall || die
make DESTDIR=${D} install || die
+ # Do not install charset.alias for ppc-macos since it already exists.
+ if (use macos || use ppc-macos); then
+ einfo "Not installing charset.alias on macos"
+ rm ${D}/usr/lib/charset.alias || die "Cannot remove charset.alias from the image"
+ fi
+
# Consider invalid UTF-8 filenames as locale-specific.
# FIXME : we should probably move to suggesting G_FILENAME_ENC
dodir /etc/env.d