summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-06-17 10:17:47 +0000
committerPeter Volkov <pva@gentoo.org>2009-06-17 10:17:47 +0000
commit5f481ac6d028929e09ea87d13d993cc8cbf03fe1 (patch)
tree2b2df5c81c83fb8d1dbe49917aedaf061d1aa3f4 /dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild
parentVersion bump. Dropped old. (diff)
downloadgentoo-2-5f481ac6d028929e09ea87d13d993cc8cbf03fe1.tar.gz
gentoo-2-5f481ac6d028929e09ea87d13d993cc8cbf03fe1.tar.bz2
gentoo-2-5f481ac6d028929e09ea87d13d993cc8cbf03fe1.zip
Version bump. Dropped old.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild')
-rw-r--r--dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild b/dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild
new file mode 100644
index 000000000000..bcd72a59f4ee
--- /dev/null
+++ b/dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/guiloader-c++/guiloader-c++-2.15.0.ebuild,v 1.1 2009/06/17 10:17:47 pva Exp $
+
+DESCRIPTION="C++ binding to GuiLoader library"
+HOMEPAGE="http://crow-designer.sourceforge.net"
+SRC_URI="mirror://sourceforge/crow-designer/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="nls"
+
+RDEPEND=">=dev-cpp/gtkmm-2.14.3
+ >=dev-cpp/glibmm-2.18
+ >=dev-libs/guiloader-2.15"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.17 )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc doc/{authors.txt,news.en.txt,readme.en.txt} || die
+}