summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 03:21:16 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 03:21:16 +0000
commit7fa418e14ac882971d7aa21a8aafae4ca9278176 (patch)
tree1a69fbac0bfd132810a6d0d8594fc5d53899c43f /dev-libs/http-fetcher
parentold (diff)
downloadgentoo-2-7fa418e14ac882971d7aa21a8aafae4ca9278176.tar.gz
gentoo-2-7fa418e14ac882971d7aa21a8aafae4ca9278176.tar.bz2
gentoo-2-7fa418e14ac882971d7aa21a8aafae4ca9278176.zip
Do not build with strict code flags #227549.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-libs/http-fetcher')
-rw-r--r--dev-libs/http-fetcher/ChangeLog7
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild20
2 files changed, 15 insertions, 12 deletions
diff --git a/dev-libs/http-fetcher/ChangeLog b/dev-libs/http-fetcher/ChangeLog
index 75762746d71c..ecec63897a1f 100644
--- a/dev-libs/http-fetcher/ChangeLog
+++ b/dev-libs/http-fetcher/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/http-fetcher
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/http-fetcher/ChangeLog,v 1.21 2007/07/02 14:53:14 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/http-fetcher/ChangeLog,v 1.22 2009/01/14 03:21:16 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org> http-fetcher-1.1.0.ebuild:
+ Do not build with strict code flags #227549.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org>
http-fetcher-1.0.2.ebuild, http-fetcher-1.0.3.ebuild,
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild
index 1abc773156a4..aa1a0cf464b0 100644
--- a/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild
@@ -1,28 +1,28 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild,v 1.6 2007/07/02 14:53:14 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/http-fetcher/http-fetcher-1.1.0.ebuild,v 1.7 2009/01/14 03:21:16 vapier Exp $
MY_P="${P/-/_}"
S="${WORKDIR}/${MY_P}"
-DESCRIPTION="HTTP Fetcher is a small, robust, flexible library for downloading files via HTTP using the GET method."
-HOMEPAGE="http://http-fetcher.sourceforge.net"
+DESCRIPTION="small, robust, flexible library for downloading files via HTTP using the GET method"
+HOMEPAGE="http://http-fetcher.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-RESTRICT="mirror"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ppc x86"
IUSE="debug"
-RDEPEND="virtual/libc"
-
src_compile() {
- econf --enable-strict $(use_enable debug) || die "econf failed"
+ econf \
+ --disable-strict \
+ $(use_enable debug) \
+ || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
dohtml -r docs/index.html docs/html
- dodoc README ChangeLog CREDITS INSTALL LICENSE
+ dodoc README ChangeLog CREDITS INSTALL
}