summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-02-02 21:54:59 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-02-02 21:54:59 +0000
commit03dec136346b675bde7da4fa2f87c7f466a31957 (patch)
treecf2e8eb0eb19b15ed00c5a3efb3b28d80ef11c70 /dev-libs/icu/icu-3.8.1-r1.ebuild
parentdisable gtk (bug #168172) (diff)
downloadgentoo-2-03dec136346b675bde7da4fa2f87c7f466a31957.tar.gz
gentoo-2-03dec136346b675bde7da4fa2f87c7f466a31957.tar.bz2
gentoo-2-03dec136346b675bde7da4fa2f87c7f466a31957.zip
adding patch for CVE-2007-{4770,4771} per bug #208001, thanks to jakub
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-libs/icu/icu-3.8.1-r1.ebuild')
-rw-r--r--dev-libs/icu/icu-3.8.1-r1.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/icu/icu-3.8.1-r1.ebuild b/dev-libs/icu/icu-3.8.1-r1.ebuild
new file mode 100644
index 000000000000..66c98c129734
--- /dev/null
+++ b/dev-libs/icu/icu-3.8.1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-3.8.1-r1.ebuild,v 1.1 2008/02/02 21:54:58 hoffie Exp $
+
+inherit eutils versionator
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
+
+BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
+DOCS_PV="$(get_version_component_range 1-2)"
+DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
+DOCS_PV="${DOCS_PV/./_}"
+SRCPKG="${PN}4c-${PV//./_}-src.tgz"
+USERGUIDE="${PN}-${DOCS_PV}-userguide.zip"
+APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
+
+SRC_URI="${BASEURI}/${SRCPKG}
+ doc? ( ${DOCS_BASEURI}/${USERGUIDE}
+ ${DOCS_BASEURI}/${APIDOCS} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}/source
+
+src_unpack() {
+ unpack ${SRCPKG}
+ if use doc ; then
+ mkdir userguide
+ pushd ./userguide > /dev/null
+ unpack ${USERGUIDE}
+ popd
+
+ mkdir apidocs
+ pushd ./apidocs > /dev/null
+ unpack ${APIDOCS}
+ popd
+ fi
+
+ # See http://qa.openoffice.org/issues/show_bug.cgi?id=83146
+ # and http://bugs.icu-project.org/trac/ticket/5498 for details
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.8-setBreakType-public.diff
+
+ # Bug 208001
+ epatch "${FILESDIR}"/${PN}-3.8-regexp-CVE-2007-4770+4771.diff
+
+ # do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # http://bugs.icu-project.org/trac/ticket/6102
+ for x in CFLAGS CXXFLAGS CPPFLAGS LDFLAGS ; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" config/Makefile.inc.in || die "sed failed"
+ done
+}
+
+src_compile() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html/userguide
+ doins -r "${WORKDIR}"/userguide/*
+
+ insinto /usr/share/doc/${PF}/html/apidocs
+ doins -r "${WORKDIR}"/apidocs/*
+ fi
+}