summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-08-23 10:17:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-08-23 10:17:39 +0000
commitf44f07287f4608e2903a4b4e34d3d4484d804b5c (patch)
treedc5dc1eef1260571cc1ed0a7f7170aea10466d3b /dev-libs/icu
parentVersion bump. (diff)
downloadgentoo-2-f44f07287f4608e2903a4b4e34d3d4484d804b5c.tar.gz
gentoo-2-f44f07287f4608e2903a4b4e34d3d4484d804b5c.tar.bz2
gentoo-2-f44f07287f4608e2903a4b4e34d3d4484d804b5c.zip
Add patch to fix time-based test. Add icu 53, should work with lo 4.2.6. bug#520322 and bug#506916
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog10
-rw-r--r--dev-libs/icu/files/icu-fix-tests-depending-on-date.patch15
-rw-r--r--dev-libs/icu/icu-52.1.ebuild5
-rw-r--r--dev-libs/icu/icu-53.1.ebuild135
4 files changed, 162 insertions, 3 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index d0be4d262ae1..86ca66acf5f7 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.277 2014/08/21 10:38:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.278 2014/08/23 10:17:39 scarabeus Exp $
+
+*icu-53.1 (23 Aug 2014)
+
+ 23 Aug 2014; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/icu-fix-tests-depending-on-date.patch, +icu-53.1.ebuild,
+ icu-52.1.ebuild:
+ Add patch to fix time-based test. Add icu 53, should work with lo 4.2.6.
+ bug#520322 and bug#506916
21 Aug 2014; Agostino Sarubbo <ago@gentoo.org> icu-52.1.ebuild:
Stable for ppc64, wrt bug #512012
diff --git a/dev-libs/icu/files/icu-fix-tests-depending-on-date.patch b/dev-libs/icu/files/icu-fix-tests-depending-on-date.patch
new file mode 100644
index 000000000000..61c286a54c10
--- /dev/null
+++ b/dev-libs/icu/files/icu-fix-tests-depending-on-date.patch
@@ -0,0 +1,15 @@
+See icu-fix-tests-depending-on-date.patch
+
+Index: icu/source/test/intltest/dtfmttst.cpp
+===================================================================
+--- icu.orig/source/test/intltest/dtfmttst.cpp
++++ icu/source/test/intltest/dtfmttst.cpp
+@@ -1132,7 +1132,7 @@ DateFormatTest::TestTwoDigitYear()
+ return;
+ }
+ parse2DigitYear(fmt, "5/6/17", date(117, UCAL_JUNE, 5));
+- parse2DigitYear(fmt, "4/6/34", date(34, UCAL_JUNE, 4));
++ parse2DigitYear(fmt, "4/6/34", date(134, UCAL_JUNE, 4));
+ }
+
+ // -------------------------------------
diff --git a/dev-libs/icu/icu-52.1.ebuild b/dev-libs/icu/icu-52.1.ebuild
index 3f72c407fe02..e24cbe985a0f 100644
--- a/dev-libs/icu/icu-52.1.ebuild
+++ b/dev-libs/icu/icu-52.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-52.1.ebuild,v 1.11 2014/08/21 10:38:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-52.1.ebuild,v 1.12 2014/08/23 10:17:39 scarabeus Exp $
EAPI=5
@@ -27,7 +27,8 @@ S="${WORKDIR}/${PN}/source"
src_prepare() {
local variable
-
+
+ epatch "${FILESDIR}/icu-fix-tests-depending-on-date.patch"
epatch_user
# Do not hardcode flags in icu-config and icu-*.pc files.
diff --git a/dev-libs/icu/icu-53.1.ebuild b/dev-libs/icu/icu-53.1.ebuild
new file mode 100644
index 000000000000..482f2018353f
--- /dev/null
+++ b/dev-libs/icu/icu-53.1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-53.1.ebuild,v 1.1 2014/08/23 10:17:39 scarabeus Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs autotools multilib-minimal
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
+
+LICENSE="BSD"
+
+SLOT="0/52"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ )
+"
+
+S="${WORKDIR}/${PN}/source"
+
+src_prepare() {
+ local variable
+
+ epatch "${FILESDIR}/icu-fix-tests-depending-on-date.patch"
+ epatch_user
+
+ # Do not hardcode flags in icu-config and icu-*.pc files.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed \
+ -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
+ -i config/icu.pc.in \
+ -i config/Makefile.inc.in \
+ || die
+ done
+
+ # Disable renaming as it is stupind thing to do
+ sed -i \
+ -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
+ common/unicode/uconfig.h || die
+
+ # Fix linking of icudata
+ sed -i \
+ -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
+ config/mh-linux || die
+
+ # Append doxygen configuration to configure
+ sed -i \
+ -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ if tc-is-cross-compiler; then
+ mkdir "${WORKDIR}"/host || die
+ pushd "${WORKDIR}"/host >/dev/null || die
+
+ CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
+ CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
+ RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
+ "${S}"/configure --disable-renaming --disable-debug \
+ --disable-samples --enable-static || die
+ emake
+
+ popd >/dev/null || die
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-renaming
+ --disable-samples
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ )
+
+ multilib_is_native_abi && myeconfargs+=(
+ $(use_enable examples samples)
+ )
+ tc-is-cross-compiler && myeconfargs+=(
+ --with-cross-build="${WORKDIR}"/host
+ )
+
+ # icu tries to use clang by default
+ tc-export CC CXX
+
+ ECONF_SOURCE=${S} \
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
+multilib_src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 VERBOSE="1" check
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use doc; then
+ dohtml -p api -r doc/html/
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dohtml ../readme.html
+}