summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-10-21 07:42:19 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-10-21 07:42:19 +0000
commitec60cf59432f684f7817c192201a85a48305283c (patch)
tree4660e76bf2cc3e6fd1a6184cb686c428f40088cb /dev-libs/jansson
parentBump (diff)
downloadgentoo-2-ec60cf59432f684f7817c192201a85a48305283c.tar.gz
gentoo-2-ec60cf59432f684f7817c192201a85a48305283c.tar.bz2
gentoo-2-ec60cf59432f684f7817c192201a85a48305283c.zip
Version bump to 2.5; fixes bug #485916, proxied commit for Johan Bergström.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-libs/jansson')
-rw-r--r--dev-libs/jansson/ChangeLog7
-rw-r--r--dev-libs/jansson/jansson-2.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-libs/jansson/ChangeLog b/dev-libs/jansson/ChangeLog
index 3b615b173bf6..5451aae7f7ac 100644
--- a/dev-libs/jansson/ChangeLog
+++ b/dev-libs/jansson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jansson
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jansson/ChangeLog,v 1.13 2013/10/21 07:27:43 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jansson/ChangeLog,v 1.14 2013/10/21 07:42:19 tomwij Exp $
+
+*jansson-2.5 (21 Oct 2013)
+
+ 21 Oct 2013; Tom Wijsman <TomWij@gentoo.org> +jansson-2.5.ebuild:
+ Version bump to 2.5; fixes bug #485916, proxied commit for Johan Bergström.
21 Oct 2013; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Reordered metadata to make automatic assignment easier.
diff --git a/dev-libs/jansson/jansson-2.5.ebuild b/dev-libs/jansson/jansson-2.5.ebuild
new file mode 100644
index 000000000000..4d65f5351010
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jansson/jansson-2.5.ebuild,v 1.1 2013/10/21 07:42:19 tomwij Exp $
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+DOCS=(CHANGES README.rst)
+
+src_prepare() {
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
+ autotools-utils_src_install
+}