summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2012-02-26 04:05:32 +0000
committerJory Pratt <anarchy@gentoo.org>2012-02-26 04:05:32 +0000
commit41d4d864668151fa827a42ec8ec1669859b1f34b (patch)
tree39017fcb3c5a428f57e0eaffdb991982284b9638 /dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild
parentSet EAPI=4. (diff)
downloadgentoo-2-41d4d864668151fa827a42ec8ec1669859b1f34b.tar.gz
gentoo-2-41d4d864668151fa827a42ec8ec1669859b1f34b.tar.bz2
gentoo-2-41d4d864668151fa827a42ec8ec1669859b1f34b.zip
Fix bug #403945 and #398675
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild')
-rw-r--r--dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild b/dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..73a45e2e693c
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.2.5-r1.ebuild,v 1.1 2012/02/26 04:05:32 anarchy Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+IUSE="debug static-libs stats"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PN}-strip-optimization.patch" \
+ "${FILESDIR}/${PN}-2.2.1-no-pprof.patch" \
+ "${FILESDIR}/${PN}-2.2.5_fix_html_install.patch" \
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-jemalloc-prefix=j \
+ $(use_enable debug) \
+ $(use_enable stats)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+ dodoc ChangeLog README
+ dohtml doc/jemalloc.html
+
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
+}