summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-16 08:38:15 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-16 08:38:15 +0000
commit03e5df4503af42cfe46cff008521be1367379f57 (patch)
tree2948343d673474c4424b4f06d525d244bc355f7b /dev-libs/jrtplib
parentApply upstream patch 20080718 correctly (#247607). (diff)
downloadgentoo-2-03e5df4503af42cfe46cff008521be1367379f57.tar.gz
gentoo-2-03e5df4503af42cfe46cff008521be1367379f57.tar.bz2
gentoo-2-03e5df4503af42cfe46cff008521be1367379f57.zip
Fixed gcc-4.3 build problem, bug #227551, thank Evil Compile Person for report and Yaroslav Gorbunov, Marek Miller for the fix.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'dev-libs/jrtplib')
-rw-r--r--dev-libs/jrtplib/ChangeLog9
-rw-r--r--dev-libs/jrtplib/files/jrtplib-3.7.1-gcc43.patch24
-rw-r--r--dev-libs/jrtplib/jrtplib-3.7.1.ebuild12
3 files changed, 41 insertions, 4 deletions
diff --git a/dev-libs/jrtplib/ChangeLog b/dev-libs/jrtplib/ChangeLog
index 7d922ccf52ad..e8f89f317f93 100644
--- a/dev-libs/jrtplib/ChangeLog
+++ b/dev-libs/jrtplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jrtplib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/ChangeLog,v 1.5 2007/12/15 15:34:12 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/ChangeLog,v 1.6 2008/12/16 08:38:15 pva Exp $
+
+ 16 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/jrtplib-3.7.1-gcc43.patch, jrtplib-3.7.1.ebuild:
+ Fixed gcc-4.3 build problem, bug #227551, thank Evil Compile Person for
+ report and Yaroslav Gorbunov, Marek Miller for the fix.
*jrtplib-3.7.1 (15 Dec 2007)
diff --git a/dev-libs/jrtplib/files/jrtplib-3.7.1-gcc43.patch b/dev-libs/jrtplib/files/jrtplib-3.7.1-gcc43.patch
new file mode 100644
index 000000000000..0fd2917defc0
--- /dev/null
+++ b/dev-libs/jrtplib/files/jrtplib-3.7.1-gcc43.patch
@@ -0,0 +1,24 @@
+diff -Nurpa jrtplib-3.7.1.orig/src/rtcpcompoundpacketbuilder.cpp jrtplib-3.7.1/src/rtcpcompoundpacketbuilder.cpp
+--- jrtplib-3.7.1.orig/src/rtcpcompoundpacketbuilder.cpp 2008-12-16 08:58:06.000000000 +0300
++++ jrtplib-3.7.1/src/rtcpcompoundpacketbuilder.cpp 2008-12-16 08:59:54.000000000 +0300
+@@ -42,6 +42,8 @@
+
+ #include "rtpdebug.h"
+
++#include <cstring>
++
+ RTCPCompoundPacketBuilder::RTCPCompoundPacketBuilder(RTPMemoryManager *mgr) : RTCPCompoundPacket(mgr), report(mgr), sdes(mgr)
+ {
+ byesize = 0;
+diff -Nurpa jrtplib-3.7.1.orig/src/rtppacket.cpp jrtplib-3.7.1/src/rtppacket.cpp
+--- jrtplib-3.7.1.orig/src/rtppacket.cpp 2008-12-16 08:58:06.000000000 +0300
++++ jrtplib-3.7.1/src/rtppacket.cpp 2008-12-16 08:58:52.000000000 +0300
+@@ -45,6 +45,8 @@
+
+ #include "rtpdebug.h"
+
++#include <cstring>
++
+ void RTPPacket::Clear()
+ {
+ hasextension = false;
diff --git a/dev-libs/jrtplib/jrtplib-3.7.1.ebuild b/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
index 2906e265d2c3..7c393d04f546 100644
--- a/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
+++ b/dev-libs/jrtplib/jrtplib-3.7.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/jrtplib-3.7.1.ebuild,v 1.1 2007/12/15 15:34:12 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jrtplib/jrtplib-3.7.1.ebuild,v 1.2 2008/12/16 08:38:15 pva Exp $
+
+inherit eutils
DESCRIPTION="JRTPLIB is an object-oriented RTP library written in C++."
HOMEPAGE="http://research.edm.luc.ac.be/jori/jrtplib/jrtplib.html"
@@ -14,6 +16,12 @@ IUSE="examples ipv6"
RDEPEND="dev-libs/jthread"
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_compile() {
econf $(use_enable ipv6 IPv6)
emake || die "emake failed."