summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-25 19:39:10 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-25 19:39:10 +0000
commit930419317a5158e049484415b549e9ae4cdc4c64 (patch)
tree8dffa1a35133d06307b648a574256febad976f08 /dev-libs/json-glib
parentrevbump to cmake-multilib, add myself as maint (bug 466820) (diff)
downloadgentoo-2-930419317a5158e049484415b549e9ae4cdc4c64.tar.gz
gentoo-2-930419317a5158e049484415b549e9ae4cdc4c64.tar.bz2
gentoo-2-930419317a5158e049484415b549e9ae4cdc4c64.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/json-glib')
-rw-r--r--dev-libs/json-glib/ChangeLog7
-rw-r--r--dev-libs/json-glib/json-glib-0.16.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/json-glib/ChangeLog b/dev-libs/json-glib/ChangeLog
index b9c5ca3d8440..0b76b88ab4f7 100644
--- a/dev-libs/json-glib/ChangeLog
+++ b/dev-libs/json-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/json-glib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-glib/ChangeLog,v 1.48 2013/04/01 18:23:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-glib/ChangeLog,v 1.49 2013/04/25 19:39:10 pacho Exp $
+
+*json-glib-0.16.0 (25 Apr 2013)
+
+ 25 Apr 2013; Pacho Ramos <pacho@gentoo.org> +json-glib-0.16.0.ebuild:
+ Version bump
01 Apr 2013; Agostino Sarubbo <ago@gentoo.org> json-glib-0.15.2.ebuild:
Stable for sparc, wrt bug #458984
diff --git a/dev-libs/json-glib/json-glib-0.16.0.ebuild b/dev-libs/json-glib/json-glib-0.16.0.ebuild
new file mode 100644
index 000000000000..203905c0d48a
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-0.16.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/json-glib/json-glib-0.16.0.ebuild,v 1.1 2013/04/25 19:39:10 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG=yes
+
+inherit gnome2
+
+DESCRIPTION="A library providing GLib serialization and deserialization support for the JSON format"
+HOMEPAGE="http://live.gnome.org/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Coverage support is useless, and causes runtime problems
+ gnome2_src_configure \
+ --disable-gcov \
+ $(use_enable introspection)
+}