summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2012-12-29 20:08:06 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2012-12-29 20:08:06 +0000
commit6a5478e85228a40c29bc5582fb1e20a6e6fb4ad0 (patch)
treea31555d4f291cfa870ed62115a71f72662f6b3e2 /dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild
parentDo not install static library in /lib (bug #449224, thanks to BillWho). Updat... (diff)
downloadgentoo-2-6a5478e85228a40c29bc5582fb1e20a6e6fb4ad0.tar.gz
gentoo-2-6a5478e85228a40c29bc5582fb1e20a6e6fb4ad0.tar.bz2
gentoo-2-6a5478e85228a40c29bc5582fb1e20a6e6fb4ad0.zip
Initial import.
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild b/dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild
new file mode 100644
index 000000000000..d327bfb1023f
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jsoncpp/jsoncpp-0.5.0.ebuild,v 1.1 2012/12/29 20:08:06 phajdan.jr Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit toolchain-funcs python-any-r1
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="http://jsoncpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+cxx_wrapper() {
+ set -- $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "$@"
+ echo "$@"
+ "$@"
+}
+
+src_compile() {
+ soname=libjsoncpp.so.${PV}
+ cxx_wrapper src/lib_json/*.cpp -Iinclude -shared -fPIC \
+ -Wl,-soname,${soname} -o ${soname} || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r include
+
+ dolib ${soname}
+ dosym ${soname} /usr/$(get_libdir)/libjsoncpp.so
+
+ if use doc; then
+ ${EPYTHON} doxybuild.py --doxygen=/usr/bin/doxygen || die
+ dohtml dist/doxygen/jsoncpp*/*
+ fi
+}