summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-11 17:48:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-11 17:48:09 +0000
commit3572060e8196bcfb2b5d23c1ec6a270be59da430 (patch)
tree1c32986042dfcadb453aca594335fe8750de3d68 /dev-libs/libRocket/libRocket-9999.ebuild
parentCommit Manifest, hung GPG password prompt (diff)
downloadgentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.tar.gz
gentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.tar.bz2
gentoo-2-3572060e8196bcfb2b5d23c1ec6a270be59da430.zip
fix build wrt #512956
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-libs/libRocket/libRocket-9999.ebuild')
-rw-r--r--dev-libs/libRocket/libRocket-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
index 2dce85a5d53b..90b0c5a7b226 100644
--- a/dev-libs/libRocket/libRocket-9999.ebuild
+++ b/dev-libs/libRocket/libRocket-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.7 2014/04/28 17:31:40 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.8 2014/06/11 17:48:09 hasufell Exp $
EAPI=5
@@ -67,11 +67,12 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
+ local abi_build_dir=${BUILD_DIR}
if multilib_is_native_abi ; then
if use python ; then
buildpybind() {
- cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+ cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
}
einfo "compiling python binding"