summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-27 11:12:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-27 11:12:09 +0000
commitd4ac0fb143cd7ec3f80ef08a533843359a6cdee2 (patch)
tree76cde10d8217f347960ef4f76c8be7e0684ba6e6 /dev-libs/libbsd/libbsd-0.4.2.ebuild
parentsmall fix (diff)
downloadgentoo-2-d4ac0fb143cd7ec3f80ef08a533843359a6cdee2.tar.gz
gentoo-2-d4ac0fb143cd7ec3f80ef08a533843359a6cdee2.tar.bz2
gentoo-2-d4ac0fb143cd7ec3f80ef08a533843359a6cdee2.zip
Version bump.
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libbsd/libbsd-0.4.2.ebuild')
-rw-r--r--dev-libs/libbsd/libbsd-0.4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libbsd/libbsd-0.4.2.ebuild b/dev-libs/libbsd/libbsd-0.4.2.ebuild
new file mode 100644
index 000000000000..a28442682a1a
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/libbsd-0.4.2.ebuild,v 1.1 2012/06/27 11:12:09 ssuominen Exp $
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}