summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-07-14 13:01:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-07-14 13:01:54 +0000
commit92faf3af2ead98f9790cc39084180df8ab38998b (patch)
treec31c18edbd00cab7e9cf84bd17538053784ba1ad /dev-libs/libbsd
parentamd64/x86 stable wrt bug #449586 (diff)
downloadgentoo-2-92faf3af2ead98f9790cc39084180df8ab38998b.tar.gz
gentoo-2-92faf3af2ead98f9790cc39084180df8ab38998b.tar.bz2
gentoo-2-92faf3af2ead98f9790cc39084180df8ab38998b.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/ChangeLog7
-rw-r--r--dev-libs/libbsd/libbsd-0.6.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-libs/libbsd/ChangeLog b/dev-libs/libbsd/ChangeLog
index 9f85beb788a8..7f23f830c15b 100644
--- a/dev-libs/libbsd/ChangeLog
+++ b/dev-libs/libbsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libbsd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.16 2013/06/10 04:06:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.17 2013/07/14 13:01:54 ssuominen Exp $
+
+*libbsd-0.6.0 (14 Jul 2013)
+
+ 14 Jul 2013; Samuli Suominen <ssuominen@gentoo.org> +libbsd-0.6.0.ebuild:
+ Version bump.
*libbsd-0.5.2 (10 Jun 2013)
diff --git a/dev-libs/libbsd/libbsd-0.6.0.ebuild b/dev-libs/libbsd/libbsd-0.6.0.ebuild
new file mode 100644
index 000000000000..38295889d410
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/libbsd-0.6.0.ebuild,v 1.1 2013/07/14 13:01:54 ssuominen Exp $
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DOCS="ChangeLog README TODO"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}