summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-05-18 10:33:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-05-18 10:33:38 +0000
commit0eece392629bac1dd212482252fe8485dcd94949 (patch)
tree72e859b7d93cabcd0dc467c76ba4fa0ac7756605 /dev-libs/libbulletml
parentDo not start pcmanfm with -d option. Bug #367639 (diff)
downloadgentoo-2-0eece392629bac1dd212482252fe8485dcd94949.tar.gz
gentoo-2-0eece392629bac1dd212482252fe8485dcd94949.tar.bz2
gentoo-2-0eece392629bac1dd212482252fe8485dcd94949.zip
Fix build with gcc-4.6 Bug #367883
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libbulletml')
-rw-r--r--dev-libs/libbulletml/ChangeLog6
-rw-r--r--dev-libs/libbulletml/files/libbulletml-0.0.6-gcc46.patch20
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-libs/libbulletml/ChangeLog b/dev-libs/libbulletml/ChangeLog
index 41b78919b589..5942e781a72b 100644
--- a/dev-libs/libbulletml/ChangeLog
+++ b/dev-libs/libbulletml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libbulletml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/ChangeLog,v 1.8 2011/04/13 14:34:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/ChangeLog,v 1.9 2011/05/18 10:33:38 tupone Exp $
+
+ 18 May 2011; Tupone Alfredo <tupone@gentoo.org> libbulletml-0.0.6.ebuild,
+ +files/libbulletml-0.0.6-gcc46.patch:
+ Fix build with gcc-4.6 Bug #367883 by Diego Elio Pettenò
13 Apr 2011; Alfredo Tupone <tupone@gentoo.org> libbulletml-0.0.6.ebuild:
Depend on dev-libs/boost, remove local copy. Bug #363187 by Steven Wilson
diff --git a/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc46.patch b/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc46.patch
new file mode 100644
index 000000000000..47e0dc411ac9
--- /dev/null
+++ b/dev-libs/libbulletml/files/libbulletml-0.0.6-gcc46.patch
@@ -0,0 +1,20 @@
+--- calc.yy.old 2011-05-18 12:26:38.701666366 +0200
++++ calc.yy 2011-05-18 12:27:43.020672135 +0200
+@@ -17,7 +17,7 @@
+ #include "formula.h"
+ #include "formula-variables.h"
+
+-int yyerror(char* s);
++int yyerror(const char* s);
+ int yylex();
+
+ const char* yyinStr;
+@@ -149,7 +149,7 @@
+ return c;
+ }
+
+-int yyerror(char* s) {
++int yyerror(const char* s) {
+ printf("yyerror: %s\n", s);
+ return 0;
+ }
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
index 2433c62427a2..aef91ca172e6 100644
--- a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.7 2011/04/13 14:34:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbulletml/libbulletml-0.0.6.ebuild,v 1.8 2011/05/18 10:33:38 tupone Exp $
EAPI=2
inherit eutils
@@ -20,7 +20,8 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN#lib}/src"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
rm -r boost || die "remove of local boost failed"
}