summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-05-01 00:06:16 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-05-01 00:06:16 +0000
commit13845b80981e9d316743363bc0542c8d832b17c5 (patch)
tree541d39fd03cb18116ea33253fe6003e4c5eecc80 /dev-libs/libcoyotl
parentFix building with gcc-4.3 (diff)
downloadgentoo-2-13845b80981e9d316743363bc0542c8d832b17c5.tar.gz
gentoo-2-13845b80981e9d316743363bc0542c8d832b17c5.tar.bz2
gentoo-2-13845b80981e9d316743363bc0542c8d832b17c5.zip
Added fix for gcc-4.3 (bug #214176, thanks to Peter Alfredsen and Debian), added doc USE-flag to make doc-generation less magical.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'dev-libs/libcoyotl')
-rw-r--r--dev-libs/libcoyotl/ChangeLog9
-rw-r--r--dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch32
-rw-r--r--dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild34
3 files changed, 67 insertions, 8 deletions
diff --git a/dev-libs/libcoyotl/ChangeLog b/dev-libs/libcoyotl/ChangeLog
index 0abf91bb1ce6..d86118e59ee4 100644
--- a/dev-libs/libcoyotl/ChangeLog
+++ b/dev-libs/libcoyotl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libcoyotl
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/ChangeLog,v 1.8 2007/02/22 00:52:47 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/ChangeLog,v 1.9 2008/05/01 00:06:15 dev-zero Exp $
+
+ 01 May 2008; Tiziano Müller <dev-zero@gentoo.org>
+ +files/3.1.0-gcc-4.3.patch, libcoyotl-3.1.0.ebuild:
+ Added fix for gcc-4.3 (bug #214176, thanks to Peter Alfredsen and Debian),
+ added doc USE-flag to make doc-generation less magical.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch b/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch
new file mode 100644
index 000000000000..4d3391e21161
--- /dev/null
+++ b/dev-libs/libcoyotl/files/3.1.0-gcc-4.3.patch
@@ -0,0 +1,32 @@
+diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp libcoyotl-3.1.0/libcoyotl/command_line.cpp
+--- libcoyotl-3.1.0.orig/libcoyotl/command_line.cpp 2008-03-21 22:41:41.000000000 +0100
++++ libcoyotl-3.1.0/libcoyotl/command_line.cpp 2008-03-21 22:41:59.000000000 +0100
+@@ -30,10 +30,13 @@
+ // http://www.coyotegulch.com
+ //
+ //-----------------------------------------------------------------------
+
+ #include "command_line.h"
++
++#include <cstring>
++
+ using namespace libcoyotl;
+
+ command_line::command_line(int argc, char * argv[], const set<string> & bool_opts)
+ : m_options(),
+ m_inputs(),
+diff -NrU5 libcoyotl-3.1.0.orig/libcoyotl/sortutil.h libcoyotl-3.1.0/libcoyotl/sortutil.h
+--- libcoyotl-3.1.0.orig/libcoyotl/sortutil.h 2008-03-21 22:41:41.000000000 +0100
++++ libcoyotl-3.1.0/libcoyotl/sortutil.h 2008-03-21 22:41:59.000000000 +0100
+@@ -34,10 +34,11 @@
+ //-----------------------------------------------------------------------
+
+ #if !defined(LIBCOYOTL_SORTUTIL_H)
+ #define LIBCOYOTL_SORTUTIL_H
+
++#include <climits>
+ #include <stdexcept>
+
+ namespace libcoyotl
+ {
+
diff --git a/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild b/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild
index a582cd24c966..7dcbaef30a11 100644
--- a/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild
+++ b/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild,v 1.1 2005/12/18 23:19:31 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/libcoyotl-3.1.0.ebuild,v 1.2 2008/05/01 00:06:15 dev-zero Exp $
+
+inherit eutils
DESCRIPTION="A collection of portable C++ classes."
HOMEPAGE="http://www.coyotegulch.com/products/libcoyotl/"
@@ -8,10 +10,30 @@ SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="media-libs/libpng"
+IUSE="doc"
+
+RDEPEND="media-libs/libpng"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc-4.3.patch"
+}
+
+src_compile() {
+ ac_cv_prog_HAVE_DOXYGEN="false" econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd docs
+ doxygen libcoyotl.doxygen || die "generating docs failed"
+ fi
+}
src_install() {
- make DESTDIR="${D}" install
- dodoc ChangeLog NEWS README
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml docs/html/*
}