summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-29 14:22:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-29 14:22:25 +0000
commitaf0286e4b449febae72e67abcafcf044c927ca55 (patch)
treee40a02e025a09b6a67871bc801a7f2fcd8d697b5 /dev-libs/libebml
parent[sys-cluster/maui] Reloacte spool to var not to usr (diff)
downloadgentoo-2-af0286e4b449febae72e67abcafcf044c927ca55.tar.gz
gentoo-2-af0286e4b449febae72e67abcafcf044c927ca55.tar.bz2
gentoo-2-af0286e4b449febae72e67abcafcf044c927ca55.zip
version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libebml')
-rw-r--r--dev-libs/libebml/ChangeLog7
-rw-r--r--dev-libs/libebml/libebml-1.2.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libebml/ChangeLog b/dev-libs/libebml/ChangeLog
index 74b5175a1028..8b13794a7eea 100644
--- a/dev-libs/libebml/ChangeLog
+++ b/dev-libs/libebml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libebml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.104 2011/05/28 11:46:47 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.105 2011/06/29 14:22:25 aballier Exp $
+
+*libebml-1.2.1 (29 Jun 2011)
+
+ 29 Jun 2011; Alexis Ballier <aballier@gentoo.org> +libebml-1.2.1.ebuild:
+ version bump
28 May 2011; Brent Baude <ranger@gentoo.org> libebml-1.0.0.ebuild:
Marking libebml-1.0.0 ppc for bug 329633
diff --git a/dev-libs/libebml/libebml-1.2.1.ebuild b/dev-libs/libebml/libebml-1.2.1.ebuild
new file mode 100644
index 000000000000..852dd134aec6
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-1.2.1.ebuild,v 1.1 2011/06/29 14:22:25 aballier Exp $
+
+EAPI=2
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${P}/make/linux"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-makefile-fixup.patch
+}
+
+src_compile() {
+ # keep the prefix in here to make sure the binary is built with a correct
+ # install_name on Darwin
+ emake \
+ prefix="${EPREFIX}/usr" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ install || die "emake install failed"
+
+ dodoc "${WORKDIR}/${P}/ChangeLog"
+}