summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-26 00:15:31 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-26 00:15:31 +0000
commitc5f13a20688048d416408604f38e03a8413483d4 (patch)
tree78cb17b1bfbf43a8ec6f202e913bf8bce3ccfdf5 /dev-libs/libebml
parentMove libX11 from RDEPEND to DEPEND. It's not linked against, and xwininfo onl... (diff)
downloadgentoo-2-c5f13a20688048d416408604f38e03a8413483d4.tar.gz
gentoo-2-c5f13a20688048d416408604f38e03a8413483d4.tar.bz2
gentoo-2-c5f13a20688048d416408604f38e03a8413483d4.zip
Version bump. Add static-libs use flag (bug #381661), add debug use flag, update to EAPI 4.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libebml')
-rw-r--r--dev-libs/libebml/ChangeLog8
-rw-r--r--dev-libs/libebml/libebml-1.2.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/libebml/ChangeLog b/dev-libs/libebml/ChangeLog
index 739d7a9fc54a..1ba4cc7cec55 100644
--- a/dev-libs/libebml/ChangeLog
+++ b/dev-libs/libebml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libebml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.109 2011/09/24 16:53:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/ChangeLog,v 1.110 2011/09/26 00:15:31 radhermit Exp $
+
+*libebml-1.2.2 (26 Sep 2011)
+
+ 26 Sep 2011; Tim Harder <radhermit@gentoo.org> +libebml-1.2.2.ebuild:
+ Version bump. Add static-libs use flag (bug #381661), add debug use flag,
+ update to EAPI 4.
24 Sep 2011; Raúl Porcel <armin76@gentoo.org> libebml-1.2.1.ebuild:
alpha/ia64/sparc stable wrt #376395
diff --git a/dev-libs/libebml/libebml-1.2.2.ebuild b/dev-libs/libebml/libebml-1.2.2.ebuild
new file mode 100644
index 000000000000..e64608a029fa
--- /dev/null
+++ b/dev-libs/libebml/libebml-1.2.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libebml/libebml-1.2.2.ebuild,v 1.1 2011/09/26 00:15:31 radhermit Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Extensible binary format library (kinda like XML)"
+HOMEPAGE="http://www.matroska.org/"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug static-libs"
+
+S="${WORKDIR}/${P}/make/linux"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-makefile-fixup.patch
+
+ sed -i -e "s:\(DEBUGFLAGS=\)-g :\1:" Makefile || die
+}
+
+src_compile() {
+ local targets
+ if [[ ${CHOST} != *-darwin* ]] ; then
+ targets="sharedlib"
+ else
+ targets="macholib"
+ fi
+ use static-libs && targets+=" staticlib"
+
+ # keep the prefix in here to make sure the binary is built with a correct
+ # install_name on Darwin
+ emake \
+ prefix="${EPREFIX}/usr" \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ $(use debug && echo DEBUG=yes || echo DEBUG=no) \
+ ${targets}
+}
+
+src_install() {
+ local targets="install_headers"
+ if [[ ${CHOST} != *-darwin* ]] ; then
+ targets+=" install_sharedlib"
+ else
+ targets+=" install_macholib"
+ fi
+ use static-libs && targets+=" install_staticlib"
+
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ ${targets}
+
+ dodoc "${WORKDIR}/${P}/ChangeLog"
+}