summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoel Martin <kanaka@gentoo.org>2007-06-20 04:17:29 +0000
committerJoel Martin <kanaka@gentoo.org>2007-06-20 04:17:29 +0000
commita103373a4b5c7d5862f9fc3d4b1fd7da9c5a2e66 (patch)
treea4dc73edfca4f3b03febb95c8ff00fc4a6aff0e1 /dev-libs/libelf/files
parentadd up-to-date gnash cvs ebuild (diff)
downloadgentoo-2-a103373a4b5c7d5862f9fc3d4b1fd7da9c5a2e66.tar.gz
gentoo-2-a103373a4b5c7d5862f9fc3d4b1fd7da9c5a2e66.tar.bz2
gentoo-2-a103373a4b5c7d5862f9fc3d4b1fd7da9c5a2e66.zip
Paraellel make fixes still needed during install phase. installdirs needs to be prereq of all targets that are installing files.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-libs/libelf/files')
-rw-r--r--dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch b/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch
new file mode 100644
index 000000000000..aae82d1b375f
--- /dev/null
+++ b/dev-libs/libelf/files/libelf-0.8.9-parallelmakefix.patch
@@ -0,0 +1,29 @@
+--- libelf-0.8.9/lib/Makefile.in.orig 2007-06-20 00:09:41.876160240 -0400
++++ libelf-0.8.9/lib/Makefile.in 2007-06-20 00:10:13.601337280 -0400
+@@ -174,7 +174,7 @@ installdirs: $(top_srcdir)/mkinstalldirs
+ $(SHELL) $(top_srcdir)/mkinstalldirs $(instroot)$$dir; \
+ done
+
+-install-data:
++install-data: installdirs
+ $(INSTALL_DATA) libelf.a $(instroot)$(libdir)
+ -cd $(instroot)$(libdir) && $(RANLIB) libelf.a
+ files="$(HDRS) $(AUXHDRS) elf_repl.h"; for file in $$files; do \
+@@ -194,7 +194,7 @@ uninstall-data:
+
+ install-shared-yes: install-shared
+ install-shared-no:
+-install-shared: $(SHLIB)
++install-shared: installdirs $(SHLIB)
+ $(INSTALL_SHLIB) $(SHLIB) $(instroot)$(libdir)
+ if test "$(SONAME)" = "$(SHLIB)"; then true; else \
+ cd $(instroot)$(libdir) && $(RM) $(SONAME) && $(LN_S) $(SHLIB) $(SONAME); \
+@@ -210,7 +210,7 @@ uninstall-shared:
+
+ install-compat-yes: install-compat
+ install-compat-no:
+-install-compat:
++install-compat: installdirs
+ files="$(HDRS)"; for file in $$files; do \
+ if test -f $(instroot)$(includedir)/$$file; then true; else \
+ echo "#include <libelf/$$file>" > $(instroot)$(includedir)/$$file; \