summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-06-07 20:28:13 +0000
committerJeroen Roovers <jer@gentoo.org>2008-06-07 20:28:13 +0000
commit2ea62406d173bafae785a3cc7926a190ddd29fb6 (patch)
tree9dbb919e26e985add43b7ba72cf851420c8fe3c4 /dev-libs/libelf
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-2ea62406d173bafae785a3cc7926a190ddd29fb6.tar.gz
gentoo-2-2ea62406d173bafae785a3cc7926a190ddd29fb6.tar.bz2
gentoo-2-2ea62406d173bafae785a3cc7926a190ddd29fb6.zip
Version bump.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-libs/libelf')
-rw-r--r--dev-libs/libelf/ChangeLog9
-rw-r--r--dev-libs/libelf/libelf-0.8.10.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index 9144f1a13e16..a609eb8fb109 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libelf
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.23 2007/10/19 13:22:38 uberlord Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.24 2008/06/07 20:28:13 jer Exp $
+
+*libelf-0.8.10 (07 Jun 2008)
+
+ 07 Jun 2008; Jeroen Roovers <jer@gentoo.org> +libelf-0.8.10.ebuild:
+ Version bump.
19 Oct 2007; Roy Marples <uberlord@gentoo.org> libelf-0.8.9.ebuild:
Keyword ~x86-fbsd.
diff --git a/dev-libs/libelf/libelf-0.8.10.ebuild b/dev-libs/libelf/libelf-0.8.10.ebuild
new file mode 100644
index 000000000000..fe81d7842dfc
--- /dev/null
+++ b/dev-libs/libelf/libelf-0.8.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.10.ebuild,v 1.1 2008/06/07 20:28:13 jer Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="A ELF object file access library"
+HOMEPAGE="http://www.mr511.de/software/"
+SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls elibc_FreeBSD"
+
+DEPEND="!dev-libs/elfutils
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use elibc_FreeBSD; then
+ # Stop libelf from stamping on the system nlist.h
+ sed -i -e 's:nlist.h::g' lib/Makefile.in || die
+
+ # Enable shared libs
+ sed -i \
+ -e 's:\*-linux\*\|\*-gnu\*:\*-linux\*\|\*-gnu\*\|\*-freebsd\*:' \
+ configure || die
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ --enable-shared \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake \
+ prefix="${D}"/usr \
+ libdir="${D}"usr/$(get_libdir) \
+ install \
+ install-compat || die "emake install failed"
+ dodoc ChangeLog VERSION README
+}