summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-12-23 23:00:03 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-12-23 23:00:03 +0000
commit97032e14cf347358a73f28562b8481aace987c79 (patch)
treeef42ff5480a75e84bc23725d05002cf592945ffa /dev-libs/libgee/libgee-0.12.0.ebuild
parentVersion bump for Gnome 3.10. Move configure stuff to src_configure where it b... (diff)
downloadgentoo-2-97032e14cf347358a73f28562b8481aace987c79.tar.gz
gentoo-2-97032e14cf347358a73f28562b8481aace987c79.tar.bz2
gentoo-2-97032e14cf347358a73f28562b8481aace987c79.zip
Version bump for Gnome 3.10. Clean up old revision.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/libgee/libgee-0.12.0.ebuild')
-rw-r--r--dev-libs/libgee/libgee-0.12.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libgee/libgee-0.12.0.ebuild b/dev-libs/libgee/libgee-0.12.0.ebuild
new file mode 100644
index 000000000000..180ad8a6f69e
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.12.0.ebuild,v 1.1 2013/12/23 23:00:03 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ $(use_enable introspection)
+ VALAC="$(type -P false)"
+}