summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-04-04 14:56:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-04-04 14:56:17 +0000
commite2f2cf02be0847f30ab3673d64b00e43c8163983 (patch)
tree0c08a2143c4f829a6c3450565b3fbaf68809b76a /dev-libs/libhid
parentChanged gconf USE flag to +gconf. (diff)
downloadgentoo-2-e2f2cf02be0847f30ab3673d64b00e43c8163983.tar.gz
gentoo-2-e2f2cf02be0847f30ab3673d64b00e43c8163983.tar.bz2
gentoo-2-e2f2cf02be0847f30ab3673d64b00e43c8163983.zip
Removed -Werror, bug #260884. Fixed python dependency, bug #312189.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libhid')
-rw-r--r--dev-libs/libhid/ChangeLog10
-rw-r--r--dev-libs/libhid/libhid-0.2.16-r2.ebuild (renamed from dev-libs/libhid/libhid-0.2.16-r1.ebuild)31
2 files changed, 29 insertions, 12 deletions
diff --git a/dev-libs/libhid/ChangeLog b/dev-libs/libhid/ChangeLog
index 28c2752331ba..7c0bdfa53527 100644
--- a/dev-libs/libhid/ChangeLog
+++ b/dev-libs/libhid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libhid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.2 2009/09/23 23:53:21 matsuu Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.3 2010/04/04 14:56:17 matsuu Exp $
+
+*libhid-0.2.16-r2 (04 Apr 2010)
+
+ 04 Apr 2010; MATSUU Takuto <matsuu@gentoo.org> -libhid-0.2.16-r1.ebuild,
+ +libhid-0.2.16-r2.ebuild:
+ Removed -Werror, bug #260884. Fixed python dependency, bug #312189.
*libhid-0.2.16-r1 (23 Sep 2009)
diff --git a/dev-libs/libhid/libhid-0.2.16-r1.ebuild b/dev-libs/libhid/libhid-0.2.16-r2.ebuild
index 50b71a82a641..8b1a49b9c7e7 100644
--- a/dev-libs/libhid/libhid-0.2.16-r1.ebuild
+++ b/dev-libs/libhid/libhid-0.2.16-r2.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/libhid-0.2.16-r1.ebuild,v 1.1 2009/09/23 23:53:21 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/libhid-0.2.16-r2.ebuild,v 1.1 2010/04/04 14:56:17 matsuu Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="python? 2"
+
+inherit autotools python
-EAPI="1"
DESCRIPTION="Provides a generic and flexible way to access and interact with USB HID devices"
HOMEPAGE="http://libhid.alioth.debian.org/"
SRC_URI="http://beta.magicaltux.net/${P}.tar.gz"
@@ -15,12 +20,19 @@ IUSE="debug doc python"
RDEPEND="virtual/libusb:0"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
- python? (
- dev-lang/swig
- >=dev-lang/python-2.1.0
- )"
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # Bug #260884
+ sed -i -e 's/-Werror//' m4/md_conf_compiler.m4 || die
+ eautoconf
+}
-src_compile() {
+src_configure() {
local myconf
myconf="${myconf} $(use_with doc doxygen)"
@@ -39,7 +51,6 @@ src_compile() {
# "python" use flag is not set
econf ${myconf} || die
fi
- emake || die "emake failed"
}
src_install() {
@@ -47,6 +58,6 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README README.licence TODO || die
if use doc; then
- dohtml -r doc/html/*
+ dohtml -r doc/html/* || die
fi
}