summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-08-13 11:13:55 +0000
committerJeroen Roovers <jer@gentoo.org>2014-08-13 11:13:55 +0000
commite53e70de33d6534b263f944a61f89743cc34075c (patch)
tree65cf798a62829f4632d067eb2593cff285b64745 /dev-libs/libhid
parentUse eudev on uclibc and musl. (diff)
downloadgentoo-2-e53e70de33d6534b263f944a61f89743cc34075c.tar.gz
gentoo-2-e53e70de33d6534b263f944a61f89743cc34075c.tar.bz2
gentoo-2-e53e70de33d6534b263f944a61f89743cc34075c.zip
Add assert() patch by Martin von Gagern (bug #427010).
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/libhid')
-rw-r--r--dev-libs/libhid/ChangeLog5
-rw-r--r--dev-libs/libhid/files/libhid-0.2.16-swig.patch32
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-libs/libhid/ChangeLog b/dev-libs/libhid/ChangeLog
index 170eafa46929..6310dd365250 100644
--- a/dev-libs/libhid/ChangeLog
+++ b/dev-libs/libhid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libhid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.11 2014/08/13 11:08:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhid/ChangeLog,v 1.12 2014/08/13 11:13:55 jer Exp $
+
+ 13 Aug 2014; Jeroen Roovers <jer@gentoo.org> files/libhid-0.2.16-swig.patch:
+ Add assert() patch by Martin von Gagern (bug #427010).
*libhid-0.2.16-r4 (13 Aug 2014)
diff --git a/dev-libs/libhid/files/libhid-0.2.16-swig.patch b/dev-libs/libhid/files/libhid-0.2.16-swig.patch
index fcd4668cf001..ce5dae7481b9 100644
--- a/dev-libs/libhid/files/libhid-0.2.16-swig.patch
+++ b/dev-libs/libhid/files/libhid-0.2.16-swig.patch
@@ -11,3 +11,35 @@
if test -z "${HAVE_SWIG_TRUE}" ; then
AM_PATH_PYTHON
SWIG_PYTHON
+--- a/swig/Makefile.am
++++ b/swig/Makefile.am
+@@ -1,7 +1,7 @@
+ # AM_MAKEFLAGS = @MAKEFLAGS@
+ ACLOCAL_AMFLAGS = -I m4
+
+-AM_CPPFLAGS = $(SWIG_PYTHON_CPPFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/hidparser -DHID_INTERNAL -DSWIG
++AM_CPPFLAGS = $(SWIG_PYTHON_CPPFLAGS) -iquote$(top_srcdir)/include -I$(top_srcdir)/hidparser -DHID_INTERNAL -DSWIG
+ AM_CFLAGS = -fPIC -fno-strict-aliasing
+ AM_LDFLAGS = -shared ../src/libhid.la -lusb
+
+@@ -29,7 +29,7 @@ __init__.py: hid.py
+
+ %_wrap.c %.py: %.i $(top_srcdir)/include/hid.h
+ $(SWIG) $(SWIG_PYTHON_OPT) $(SWIG_INC) -o $@ $<
+- echo '#include <compiler.h>' > tmp.c
++ echo '#include "compiler.h"' > tmp.c
+ sed -e 's/PyObject \*self/& UNUSED/' \
+ -e 's/int flags)/int flags UNUSED)/' < $@ >> tmp.c \
+ && mv tmp.c $@
+--- a/swig/hid.i
++++ b/swig/hid.i
+@@ -1,7 +1,7 @@
+ %module(docstring="libhid is a user-space USB HID access library built on libusb.", "threads"=1) hid
+ %{
+-#include <compiler.h>
+-#include <hid.h>
++#include "compiler.h"
++#include "hid.h"
+ %}
+
+ %feature("autodoc","0");