summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-09-29 17:59:49 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-09-29 17:59:49 +0000
commitb2c5b1c3a0b2705e80f2c78ae467f782a95aba68 (patch)
tree89cf58386f3551486ea9fdb1f679d4f3bb2a3117 /dev-libs/libofx
parentStable on alpha, bug #276768 (diff)
downloadgentoo-2-b2c5b1c3a0b2705e80f2c78ae467f782a95aba68.tar.gz
gentoo-2-b2c5b1c3a0b2705e80f2c78ae467f782a95aba68.tar.bz2
gentoo-2-b2c5b1c3a0b2705e80f2c78ae467f782a95aba68.zip
Version bump to 0.9.1 Patch thanks to Tim Harder <radhermit@gmail.com> bug 286828
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/ChangeLog10
-rw-r--r--dev-libs/libofx/libofx-0.9.1.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-libs/libofx/ChangeLog b/dev-libs/libofx/ChangeLog
index 9e9ae268245d..e38d8870bc28 100644
--- a/dev-libs/libofx/ChangeLog
+++ b/dev-libs/libofx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libofx
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.46 2008/07/14 00:07:42 dirtyepic Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/ChangeLog,v 1.47 2009/09/29 17:59:49 vostorga Exp $
+
+*libofx-0.9.1 (29 Sep 2009)
+
+ 29 Sep 2009; Víctor Ostorga <vostorga@gentoo.org> +libofx-0.9.1.ebuild:
+ Version bump to 0.9.1 Patch thanks to Tim Harder <radhermit@gmail.com> bug
+ 286828
14 Jul 2008; Ryan Hill <dirtyepic@gentoo.org>
+files/libofx-0.8.3-gcc43.patch, files/libofx-0.9.0-gcc43.patch,
diff --git a/dev-libs/libofx/libofx-0.9.1.ebuild b/dev-libs/libofx/libofx-0.9.1.ebuild
new file mode 100644
index 000000000000..29a6615bddb9
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libofx/libofx-0.9.1.ebuild,v 1.1 2009/09/29 17:59:49 vostorga Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="Library to support the Open Financial eXchange XML Format"
+HOMEPAGE="http://libofx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=app-text/opensp-1.5
+ >=net-misc/curl-7.9.7
+ dev-cpp/libxmlpp:0
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ # because we redefine docdir in src_install, we need to make sure the
+ # dtd's go to the right place, LIBOFX_DTD_DIR
+ sed -i \
+ -e 's/$(DESTDIR)$(docdir)/$(DESTDIR)$(LIBOFX_DTD_DIR)/g' \
+ "${S}/dtd/Makefile.in" || die "sed failed"
+
+ # We don't want those files
+ sed -i \
+ -e '/^ COPYING/d' -e '/^ INSTALL/d' \
+ "${S}/Makefile.in" || die "sed failed"
+
+ if ! use doc; then
+ sed -i \
+ -e 's|^\(SUBDIRS = .*\) doc|\1|' \
+ "${S}/Makefile.in" || die "sed failed"
+ fi
+
+ # Fix compilation with gcc 4.3, see bug #218782
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.9.0-gcc43.patch"
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}
+ emake install DESTDIR="${D}" docdir="/usr/share/doc/${PF}" || die 'install failed'
+}
+
+pkg_postinst() {
+ elog "Please run"
+ elog " revdep-rebuild --library libofx.so.3"
+ elog "to rebuild packages linked against an older version of libofx."
+}