summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-01 22:38:02 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-01 22:38:02 +0000
commit6e79ce9f8dfb344720bbeceb66a6d5c012b1a464 (patch)
tree8e37cdeeb39dc3852f7bf618b4500932fa548811 /dev-libs/libowfat/libowfat-0.15.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-6e79ce9f8dfb344720bbeceb66a6d5c012b1a464.tar.gz
gentoo-2-6e79ce9f8dfb344720bbeceb66a6d5c012b1a464.tar.bz2
gentoo-2-6e79ce9f8dfb344720bbeceb66a6d5c012b1a464.zip
Version bumped.
Diffstat (limited to 'dev-libs/libowfat/libowfat-0.15.ebuild')
-rw-r--r--dev-libs/libowfat/libowfat-0.15.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libowfat/libowfat-0.15.ebuild b/dev-libs/libowfat/libowfat-0.15.ebuild
new file mode 100644
index 000000000000..65cdf4cdc67c
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.15.ebuild,v 1.1 2003/07/01 22:37:52 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://www.fefe.de/libowfat/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND=">=dev-libs/dietlibc-0.16"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv GNUmakefile GNUmakefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ GNUmakefile.orig > GNUmakefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make \
+ LIBDIR=${D}/usr/lib \
+ MAN3DIR=${D}/usr/share/man/man3 \
+ INCLUDEDIR=${D}/usr/include/libowfat \
+ install || die
+}