summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-11-05 06:52:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-11-05 06:52:33 +0000
commit53b73699b730d451d8a0e3bf715de89e1160d359 (patch)
treeba7c7a923a431a80539da1ef114342ea057a6c89 /dev-libs/libowfat
parentOnce againt readd or32 target (OpenRISC). Added nore binaries to RWX exempt l... (diff)
downloadgentoo-2-53b73699b730d451d8a0e3bf715de89e1160d359.tar.gz
gentoo-2-53b73699b730d451d8a0e3bf715de89e1160d359.tar.bz2
gentoo-2-53b73699b730d451d8a0e3bf715de89e1160d359.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/ChangeLog7
-rw-r--r--dev-libs/libowfat/libowfat-0.29.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/libowfat/ChangeLog b/dev-libs/libowfat/ChangeLog
index 924dbac3aab6..fdf403264790 100644
--- a/dev-libs/libowfat/ChangeLog
+++ b/dev-libs/libowfat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libowfat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.33 2012/03/22 05:52:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.34 2012/11/05 06:52:33 patrick Exp $
+
+*libowfat-0.29 (05 Nov 2012)
+
+ 05 Nov 2012; Patrick Lauer <patrick@gentoo.org> +libowfat-0.29.ebuild:
+ Bump
22 Mar 2012; Patrick Lauer <patrick@gentoo.org>
+files/libowfat-0.28-GNUmakefile.patch, libowfat-0.28-r1.ebuild:
diff --git a/dev-libs/libowfat/libowfat-0.29.ebuild b/dev-libs/libowfat/libowfat-0.29.ebuild
new file mode 100644
index 000000000000..6a4d91ffa8dd
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.29.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.29.ebuild,v 1.1 2012/11/05 06:52:33 patrick Exp $
+
+EAPI=2
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="diet"
+
+RDEPEND="diet? ( >=dev-libs/dietlibc-0.33_pre20090721 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+pkg_setup() {
+ # Required for mult/umult64.c to be usable
+ append-flags -fomit-frame-pointer
+}
+
+src_prepare() {
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET?=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ -i GNUmakefile || die "sed failed"
+ epatch "${FILESDIR}/libowfat-0.28-GNUmakefile.patch"
+}
+
+src_compile() {
+ emake -j1 \
+ CC=$(tc-getCC) \
+ $( use diet || echo 'DIET=' )
+}
+
+src_install () {
+ emake -j1 \
+ LIBDIR="${D}/usr/lib" \
+ MAN3DIR="${D}/usr/share/man/man3" \
+ INCLUDEDIR="${D}/usr/include/libowfat" \
+ install || die "emake install failed"
+
+ cd "${D}"/usr/share/man
+ mv man3/buffer.3 man3/owfat-buffer.3
+}