summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 14:43:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 14:43:14 +0000
commita007f0e5b2e43b6f2da6ace0c073893c309eea61 (patch)
tree76f54f6aa3a8ebc901036dfdeaea635e7080d8e4 /dev-libs/libowfat
parentfix selinux portage masking. (diff)
downloadgentoo-2-a007f0e5b2e43b6f2da6ace0c073893c309eea61.tar.gz
gentoo-2-a007f0e5b2e43b6f2da6ace0c073893c309eea61.tar.bz2
gentoo-2-a007f0e5b2e43b6f2da6ace0c073893c309eea61.zip
Raise dietlibc depend to >= 0.33_pre20090721 wrt #272507.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libowfat')
-rw-r--r--dev-libs/libowfat/ChangeLog8
-rw-r--r--dev-libs/libowfat/libowfat-0.28-r1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-libs/libowfat/ChangeLog b/dev-libs/libowfat/ChangeLog
index 27ec2eb37eb2..c1118015bc50 100644
--- a/dev-libs/libowfat/ChangeLog
+++ b/dev-libs/libowfat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libowfat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.24 2009/06/04 17:15:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/ChangeLog,v 1.25 2009/08/10 14:43:14 ssuominen Exp $
+
+*libowfat-0.28-r1 (10 Aug 2009)
+
+ 10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +libowfat-0.28-r1.ebuild:
+ Raise dietlibc depend to >= 0.33_pre20090721 wrt #272507.
04 Jun 2009; Patrick Lauer <patrick@gentoo.org> -libowfat-0.14.ebuild,
-libowfat-0.15.ebuild, -libowfat-0.16.ebuild, -libowfat-0.19.2.ebuild,
diff --git a/dev-libs/libowfat/libowfat-0.28-r1.ebuild b/dev-libs/libowfat/libowfat-0.28-r1.ebuild
new file mode 100644
index 000000000000..a38054db5089
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.28-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.28-r1.ebuild,v 1.1 2009/08/10 14:43:14 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/dietlibc-0.33_pre20090721"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ -i GNUmakefile || die "sed failed"
+}
+
+src_install () {
+ emake \
+ LIBDIR="${D}/usr/lib" \
+ MAN3DIR="${D}/usr/share/man/man3" \
+ INCLUDEDIR="${D}/usr/include/libowfat" \
+ install || die "emake install failed"
+
+ cd "${D}"/usr/share/man
+ mv man3/buffer.3 man3/owfat-buffer.3
+}