summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-18 21:18:51 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-18 21:18:51 +0000
commitd2a7b6d4a907572e110abea71e9e8679e9d6c01b (patch)
tree66a4e7668d477479fe60c3eb8ec40d612defbdc9 /dev-libs/libpcre/libpcre-7.8-r1.ebuild
parentInitial ebuild. (diff)
downloadgentoo-2-d2a7b6d4a907572e110abea71e9e8679e9d6c01b.tar.gz
gentoo-2-d2a7b6d4a907572e110abea71e9e8679e9d6c01b.tar.bz2
gentoo-2-d2a7b6d4a907572e110abea71e9e8679e9d6c01b.zip
Provide static libraries per bug 266016. Provide pkg-config file to link statically against libpcreposix as replacement for .la files. Remove old patch file.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libpcre/libpcre-7.8-r1.ebuild')
-rw-r--r--dev-libs/libpcre/libpcre-7.8-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/libpcre/libpcre-7.8-r1.ebuild b/dev-libs/libpcre/libpcre-7.8-r1.ebuild
deleted file mode 100644
index 0dee5ad326bf..000000000000
--- a/dev-libs/libpcre/libpcre-7.8-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpcre/libpcre-7.8-r1.ebuild,v 1.4 2009/04/12 11:05:39 loki_val Exp $
-
-EAPI=2
-
-inherit libtool eutils toolchain-funcs
-
-DESCRIPTION="Perl-compatible regular expression library"
-HOMEPAGE="http://www.pcre.org/"
-if [[ ${PV} == ${PV/_rc} ]]
-then
- MY_P="pcre-${PV}"
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${MY_P}.tar.bz2"
-else
- MY_P="pcre-${PV/_rc/-RC}"
- SRC_URI="ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/Testing/${MY_P}.tar.bz2"
-fi
-LICENSE="BSD"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bzip2 +cxx doc unicode zlib"
-
-DEPEND="dev-util/pkgconfig"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- sed -i -e "s:libdir=@libdir@:libdir=/$(get_libdir):" libpcre.pc.in || die "Fixing libpcre pkgconfig files failed"
- sed -i -e "s:-lpcre ::" libpcrecpp.pc.in || die "Fixing libpcrecpp pkgconfig files failed"
- echo "Requires: libpcre = @PACKAGE_VERSION@" >> libpcrecpp.pc.in
- elibtoolize
-}
-
-src_configure() {
- econf --with-match-limit-recursion=8192 \
- $(use_enable unicode utf8) $(use_enable unicode unicode-properties) \
- $(use_enable cxx cpp) \
- $(use_enable zlib pcregrep-libz) \
- $(use_enable bzip2 pcregrep-libbz2) \
- --disable-static \
- --enable-shared \
- --htmldir=/usr/share/doc/${PF}/html \
- --docdir=/usr/share/doc/${PF} \
- || die "econf failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- gen_usr_ldscript -a pcre
-
- dodoc doc/*.txt AUTHORS
- use doc && dohtml doc/html/*
- find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
-}