summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 18:44:15 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 18:44:15 +0000
commitaa9459f25fbcc7d8259dfff387aff5da3d04f542 (patch)
treeac56260eab54571c026c319c30596b6808e8c00f /dev-libs/librep
parent*** empty log message *** (diff)
downloadgentoo-2-aa9459f25fbcc7d8259dfff387aff5da3d04f542.tar.gz
gentoo-2-aa9459f25fbcc7d8259dfff387aff5da3d04f542.tar.bz2
gentoo-2-aa9459f25fbcc7d8259dfff387aff5da3d04f542.zip
*** empty log message ***
Diffstat (limited to 'dev-libs/librep')
-rw-r--r--dev-libs/librep/files/digest1
-rw-r--r--dev-libs/librep/librep-0.12.4-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/librep/files/digest b/dev-libs/librep/files/digest
new file mode 100644
index 000000000000..bf1134343b75
--- /dev/null
+++ b/dev-libs/librep/files/digest
@@ -0,0 +1 @@
+MD5 35ab525e59f2b518dc8e51b94b6fa354 librep-0.12.4.tar.gz
diff --git a/dev-libs/librep/librep-0.12.4-r1.ebuild b/dev-libs/librep/librep-0.12.4-r1.ebuild
new file mode 100644
index 000000000000..5e9dcd95867d
--- /dev/null
+++ b/dev-libs/librep/librep-0.12.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.12.4-r1.ebuild,v 1.1 2000/08/07 18:44:15 achim Exp $
+
+P=librep-0.12.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="dev-libs"
+DESCRIPTION="Share library implementing a Lisp dialect"
+SRC_URI="ftp://librep.sourceforge.net/pub/librep/"${A}
+HOMEPAGE="http://librep.sourceforge.net/"
+
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/usr aclocaldir=/${D}/usr/share/aclocal install
+ prepinfo
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO DOC
+ docinto doc
+ dodoc doc/*
+}
+
+
+