summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-03-08 13:47:54 +0000
committerPacho Ramos <pacho@gentoo.org>2011-03-08 13:47:54 +0000
commitd8f5ccda0b0d795e023af10efcd9f3aa1f4a3d1e (patch)
tree784bc8109d00f655e99536e402915899d2f468f1 /dev-libs/libsigc++
parentBump to 1.6.8, bugfix release (diff)
downloadgentoo-2-d8f5ccda0b0d795e023af10efcd9f3aa1f4a3d1e.tar.gz
gentoo-2-d8f5ccda0b0d795e023af10efcd9f3aa1f4a3d1e.tar.bz2
gentoo-2-d8f5ccda0b0d795e023af10efcd9f3aa1f4a3d1e.zip
Version bump fixing gcc-4.6 build (bug #354277 by Ryan Hill) and allowing building of static libs (bug #289274 by Slava Gorbunov), also simplify src_configure phase. Some fixes for libsigc++-1.2.7: don't try to install duplicated files and use proper automake version (bug #346949 by Sirko Schroeder), bump to eapi3, handle debug USE flag in a better way, fix pkg_config phase (it wasn't being executed at all). Set RDEPEND and DEPEND on all ebuilds to make repoman happy.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/ChangeLog15
-rw-r--r--dev-libs/libsigc++/files/libsigc++-1.2.7-fix-install.patch11
-rw-r--r--dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild5
-rw-r--r--dev-libs/libsigc++/libsigc++-1.2.7.ebuild29
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.9.ebuild53
5 files changed, 95 insertions, 18 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index a47866ded571..69b7046567a4 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-libs/libsigc++
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.155 2011/01/30 18:02:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.156 2011/03/08 13:47:54 pacho Exp $
+
+*libsigc++-2.2.9 (08 Mar 2011)
+
+ 08 Mar 2011; Pacho Ramos <pacho@gentoo.org> libsigc++-1.0.4-r3.ebuild,
+ libsigc++-1.2.7.ebuild, +files/libsigc++-1.2.7-fix-install.patch,
+ +libsigc++-2.2.9.ebuild:
+ Version bump fixing gcc-4.6 build (bug #354277 by Ryan Hill) and allowing
+ building of static libs (bug #289274 by Slava Gorbunov), also simplify
+ src_configure phase. Some fixes for libsigc++-1.2.7: don't try to install
+ duplicated files and use proper automake version (bug #346949 by Sirko
+ Schroeder), bump to eapi3, handle debug USE flag in a better way, fix
+ pkg_config phase (it wasn't being executed at all). Set RDEPEND and DEPEND on
+ all ebuilds to make repoman happy.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> libsigc++-2.2.7.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #348987
diff --git a/dev-libs/libsigc++/files/libsigc++-1.2.7-fix-install.patch b/dev-libs/libsigc++/files/libsigc++-1.2.7-fix-install.patch
new file mode 100644
index 000000000000..3b4703631909
--- /dev/null
+++ b/dev-libs/libsigc++/files/libsigc++-1.2.7-fix-install.patch
@@ -0,0 +1,11 @@
+--- sigc++/Makefile.am.orig 2010-11-27 20:40:35.301189910 +0930
++++ sigc++/Makefile.am 2010-11-27 20:40:46.871110361 +0930
+@@ -12,7 +12,7 @@
+ sigc_built_h = bind_return.h \
+ object_slot.h retype_return.h slot.h bind.h \
+ class_slot.h hide.h retype.h signal.h \
+- method_slot.h method_slot.h
++ method_slot.h
+
+ built_sources = $(sigc_built_cc) $(sigc_built_h)
+ dist_sources = $(sigc_fixed_cc) $(sigc_fixed_h)
diff --git a/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild b/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild
index c4fbe5d90b1c..77f41945e5c4 100644
--- a/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild,v 1.15 2010/09/13 11:40:08 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.0.4-r3.ebuild,v 1.16 2011/03/08 13:47:54 pacho Exp $
inherit eutils
@@ -14,6 +14,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc sh sparc x86"
IUSE="debug"
DEPEND=""
+RDEPEND=""
src_unpack() {
unpack ${A}
diff --git a/dev-libs/libsigc++/libsigc++-1.2.7.ebuild b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
index bd0a1ec57216..d090ce5cb5d9 100644
--- a/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
+++ b/dev-libs/libsigc++/libsigc++-1.2.7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.7.ebuild,v 1.7 2008/12/17 20:32:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-1.2.7.ebuild,v 1.8 2011/03/08 13:47:54 pacho Exp $
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.7"
+EAPI="3"
+GCONF_DEBUG="yes"
-inherit autotools gnome2
+inherit autotools gnome2 eutils
DESCRIPTION="Typesafe callback system for standard C++"
HOMEPAGE="http://libsigc.sourceforge.net/"
@@ -13,26 +13,25 @@ HOMEPAGE="http://libsigc.sourceforge.net/"
LICENSE="GPL-2 LGPL-2.1"
SLOT="1.2"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
-IUSE="debug"
+IUSE=""
RDEPEND=""
+DEPEND=""
-DOCS="AUTHORS ChangeLog FEATURES IDEAS README NEWS TODO"
-
-pkg_config() {
- use debug \
- && G2CONF="--enable-debug=yes" \
- || G2CONF="--enable-debug=no"
-
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog FEATURES IDEAS README NEWS TODO"
G2CONF="${G2CONF} --enable-maintainer-mode --enable-threads"
}
-src_unpack() {
- gnome2_src_unpack
+src_prepare() {
+ gnome2_src_prepare
# fixes bug #219041
sed -e 's:ACLOCAL_AMFLAGS = -I $(srcdir)/scripts:ACLOCAL_AMFLAGS = -I scripts:' \
-i Makefile.{in,am}
+ # Fix duplicated file installation, bug #346949
+ epatch "${FILESDIR}/${P}-fix-install.patch"
+
eautoreconf
}
diff --git a/dev-libs/libsigc++/libsigc++-2.2.9.ebuild b/dev-libs/libsigc++/libsigc++-2.2.9.ebuild
new file mode 100644
index 000000000000..6bbaa89e45a0
--- /dev/null
+++ b/dev-libs/libsigc++/libsigc++-2.2.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.9.ebuild,v 1.1 2011/03/08 13:47:54 pacho Exp $
+
+EAPI="3"
+
+inherit base eutils gnome.org flag-o-matic
+
+DESCRIPTION="Typesafe callback system for standard C++"
+HOMEPAGE="http://libsigc.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+# Needs mm-common for eautoreconf
+src_prepare() {
+ # don't waste time building examples
+ sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed examples failed"
+
+ # don't waste time building tests unless USE=test
+ if ! use test ; then
+ sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
+ Makefile.am Makefile.in || die "sed tests failed"
+ fi
+}
+
+src_configure() {
+ filter-flags -fno-exceptions
+
+ econf $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed."
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "To allow parallel installation of sigc++-1.0, sigc++-1.2, and sigc++2.0"
+ ewarn "the header files are now installed in a version specific"
+ ewarn "subdirectory. Be sure to unmerge any libsigc++ versions"
+ ewarn "< 1.0.4 that you may have previously installed."
+}