summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-10 23:52:45 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-10 23:52:45 +0000
commit8ae51a0afe015c92ad0825cd40f7b79fe9e9d312 (patch)
treeb562bc6032ce8d3ab18861bb72a3d4addbe897cb /dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild
parentFixes for installing the CLI sapi (diff)
downloadgentoo-2-8ae51a0afe015c92ad0825cd40f7b79fe9e9d312.tar.gz
gentoo-2-8ae51a0afe015c92ad0825cd40f7b79fe9e9d312.tar.bz2
gentoo-2-8ae51a0afe015c92ad0825cd40f7b79fe9e9d312.zip
Version bump for security #91421.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild')
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild
new file mode 100644
index 000000000000..401025cce15b
--- /dev/null
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.03.ebuild,v 1.1 2005/06/10 23:52:45 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="modular and portable cryptographic toolkit"
+HOMEPAGE="http://libtomcrypt.org/"
+SRC_URI="http://libtomcrypt.org/files/crypt-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+DEPEND="doc? ( virtual/tetex app-text/ghostscript )"
+RDEPEND=""
+
+src_unpack() {
+ unpack crypt-${PV}.tar.bz2
+ cd "${S}"
+ use doc || sed -i '/^install:/s:docs::' makefile
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc authors changes
+ if use doc ; then
+ docinto examples ; dodoc examples/*
+ docinto notes ; dodoc notes/*
+ docinto demos ; dodoc demos/*
+ fi
+}