summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-02 05:18:40 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-02 05:18:40 +0000
commit3c9fec710e6bea28562acbdf463b3bec100d8e57 (patch)
tree71f0a591ec220815663fc11eb480628b22b435b7 /dev-libs/libtommath
parentRemove old (bug #328383). Set DEPEND on sys-devel/libtool thanks to Bruno (bu... (diff)
downloadgentoo-2-3c9fec710e6bea28562acbdf463b3bec100d8e57.tar.gz
gentoo-2-3c9fec710e6bea28562acbdf463b3bec100d8e57.tar.bz2
gentoo-2-3c9fec710e6bea28562acbdf463b3bec100d8e57.zip
Split long line. Use autotools-utils eclass instead of find.
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/ChangeLog7
-rw-r--r--dev-libs/libtommath/libtommath-0.42.0-r1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index e89c552f78d0..0981c87081dd 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libtommath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.41 2011/08/02 05:03:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.42 2011/08/02 05:18:40 jer Exp $
+
+*libtommath-0.42.0-r1 (02 Aug 2011)
+
+ 02 Aug 2011; Jeroen Roovers <jer@gentoo.org> +libtommath-0.42.0-r1.ebuild:
+ Split long line. Use autotools-utils eclass instead of find.
02 Aug 2011; Jeroen Roovers <jer@gentoo.org> -libtommath-0.36-r1.ebuild,
-files/libtommath-0.36-CC.patch, -files/libtommath-0.36-LDFLAGS.patch,
diff --git a/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild b/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild
new file mode 100644
index 000000000000..d4eb1eeaa5f1
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.42.0-r1.ebuild,v 1.1 2011/08/02 05:18:40 jer Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils multilib toolchain-funcs
+
+DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
+HOMEPAGE="http://www.libtom.org/"
+SRC_URI="http://www.libtom.org/files/ltm-${PV}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="sys-devel/libtool"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ [[ ${CHOST} == *-darwin* ]] && \
+ sed -i -e 's/libtool/glibtool/g' makefile.shared
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) -f makefile.shared IGNORE_SPEED=1 LIBPATH="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake -f makefile.shared \
+ DESTDIR="${ED}" \
+ LIBPATH="${EPREFIX}/usr/$(get_libdir)" \
+ INCPATH="${EPREFIX}/usr/include" \
+ install
+
+ dodoc changes.txt
+
+ use doc && dodoc *.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+
+ use static-libs || remove_libtool_files
+}