summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-29 01:03:45 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-29 01:03:45 +0000
commit904e34b00b82a063da0d7c1b4cd7215f0c5bcd17 (patch)
tree7ff8f1c204f3e30b1ab193364746891be8b708b6 /dev-libs/libusb/libusb-0.1.8.ebuild
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-904e34b00b82a063da0d7c1b4cd7215f0c5bcd17.tar.gz
gentoo-2-904e34b00b82a063da0d7c1b4cd7215f0c5bcd17.tar.bz2
gentoo-2-904e34b00b82a063da0d7c1b4cd7215f0c5bcd17.zip
version bump. workaround missing .so extensions with libtool version (#42955)
Diffstat (limited to 'dev-libs/libusb/libusb-0.1.8.ebuild')
-rw-r--r--dev-libs/libusb/libusb-0.1.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libusb/libusb-0.1.8.ebuild b/dev-libs/libusb/libusb-0.1.8.ebuild
new file mode 100644
index 000000000000..f1b569b98a0d
--- /dev/null
+++ b/dev-libs/libusb/libusb-0.1.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.8.ebuild,v 1.1 2004/02/29 01:03:43 liquidx Exp $
+
+DESCRIPTION="Userspace access to USB devices"
+HOMEPAGE="http://libusb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libusb/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64"
+IUSE=""
+
+DEPEND="sys-devel/libtool
+ doc? ( app-text/openjade
+ =app-text/docbook-sgml-dtd-3.1-r1 )"
+
+src_compile() {
+ local myconf
+
+ # keep this otherwise libraries will not have .so extensions
+ libtoolize --force
+
+ use doc \
+ && myconf="--enable-build-docs" \
+ || myconf="--disable-build-docs"
+
+ use debug \
+ && myconf="${myconf} --enable-debug=all" \
+ || myconf="${myconf} --disable-debug"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS NEWS README || die
+ if use doc; then
+ dohtml doc/html/*.html || die
+ fi
+}