summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-10-20 10:10:37 +0000
committerEray Aslan <eras@gentoo.org>2012-10-20 10:10:37 +0000
commit01cda28c058f60c2b1701a7dad36b7aaf7a54e61 (patch)
treeb7b1fa414fd26e9acb52baf2d1af042f9387cb95 /dev-libs/libverto
parentarg, forgot to check testsuite, it's still broken due to upstream ignoring it (diff)
downloadgentoo-2-01cda28c058f60c2b1701a7dad36b7aaf7a54e61.tar.gz
gentoo-2-01cda28c058f60c2b1701a7dad36b7aaf7a54e61.tar.bz2
gentoo-2-01cda28c058f60c2b1701a7dad36b7aaf7a54e61.zip
Version bump
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'dev-libs/libverto')
-rw-r--r--dev-libs/libverto/ChangeLog8
-rw-r--r--dev-libs/libverto/libverto-0.2.5.ebuild52
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-libs/libverto/ChangeLog b/dev-libs/libverto/ChangeLog
index 5f7522c7570e..38f1277babe5 100644
--- a/dev-libs/libverto/ChangeLog
+++ b/dev-libs/libverto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libverto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/ChangeLog,v 1.5 2012/06/05 19:00:52 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/ChangeLog,v 1.6 2012/10/20 10:10:37 eras Exp $
+
+*libverto-0.2.5 (20 Oct 2012)
+
+ 20 Oct 2012; Eray Aslan <eras@gentoo.org> +libverto-0.2.5.ebuild:
+ Version bump
05 Jun 2012; Michael Weber <xmw@gentoo.org> libverto-0.2.4.ebuild:
adding ~ppc (bug 412489)
@@ -19,4 +24,3 @@
18 Apr 2012; Eray Aslan <eras@gentoo.org> +libverto-0.2.4.ebuild,
+metadata.xml:
initial commit
-
diff --git a/dev-libs/libverto/libverto-0.2.5.ebuild b/dev-libs/libverto/libverto-0.2.5.ebuild
new file mode 100644
index 000000000000..54b727955445
--- /dev/null
+++ b/dev-libs/libverto/libverto-0.2.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libverto/libverto-0.2.5.ebuild,v 1.1 2012/10/20 10:10:37 eras Exp $
+
+EAPI=4
+
+DESCRIPTION="Main event loop abstraction library"
+HOMEPAGE="https://fedorahosted.org/libverto/"
+SRC_URI="https://fedorahosted.org/releases/l/i/libverto/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-fbsd"
+IUSE="glib +libev libevent tevent +threads static-libs"
+
+# file collisions
+DEPEND="!=app-crypt/mit-krb5-1.10.1-r0
+ !=app-crypt/mit-krb5-1.10.1-r1
+ !=app-crypt/mit-krb5-1.10.1-r2
+ glib? ( >=dev-libs/glib-2.29 )
+ libev? ( >=dev-libs/libev-4.11 )
+ libevent? ( >=dev-libs/libevent-2.0 )
+ tevent? ( sys-libs/tevent )"
+
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( glib libev libevent tevent ) "
+
+src_prepare() {
+ # known problem uptream with tevent write test. tevent does not fire a
+ # callback on error, but we explicitly test for this behaviour. Do not run
+ # tevent tests for now.
+ sed -i -e 's/def HAVE_TEVENT/ 0/' tests/test.h || die
+}
+
+src_configure() {
+ econf \
+ $(use_with glib) \
+ $(use_with libev) \
+ $(use_with libevent) \
+ $(use_with tevent) \
+ $(use_with threads pthread) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog NEWS INSTALL README
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}