summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-12 10:01:51 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-12 10:01:51 +0000
commit6b152090dfbff6315270402254109245470e43c5 (patch)
treee30bf027acea87bbf472f0101d24a06de7aa70eb /dev-libs/libxml2
parentstill refining that new 2.4.6 linux ebuild; more improvements to come... (diff)
downloadgentoo-2-6b152090dfbff6315270402254109245470e43c5.tar.gz
gentoo-2-6b152090dfbff6315270402254109245470e43c5.tar.bz2
gentoo-2-6b152090dfbff6315270402254109245470e43c5.zip
*** empty log message ***
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.4.01
-rw-r--r--dev-libs/libxml2/libxml2-2.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.4.0 b/dev-libs/libxml2/files/digest-libxml2-2.4.0
new file mode 100644
index 000000000000..6cd1d7972423
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.4.0
@@ -0,0 +1 @@
+MD5 38634715dd81ceb2a69bac3da8b5e56c libxml2-2.4.0.tar.gz
diff --git a/dev-libs/libxml2/libxml2-2.4.0.ebuild b/dev-libs/libxml2/libxml2-2.4.0.ebuild
new file mode 100644
index 000000000000..082b12a9e877
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.0.ebuild,v 1.1 2001/07/12 10:01:51 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/libxml/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/libxml/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+ local myconf
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
+ try pmake
+}
+
+src_install() {
+ try make install prefix=${D}/usr sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
+
+
+