summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-07 14:39:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-07 14:39:52 +0000
commit2b4b02ed99892de69e78a7dc1208dad6b90c3963 (patch)
treed3448f79066c28f3249b6d25aac64965fd6cc958 /dev-libs/libxslt
parentEAPI=2 (diff)
downloadgentoo-2-2b4b02ed99892de69e78a7dc1208dad6b90c3963.tar.gz
gentoo-2-2b4b02ed99892de69e78a7dc1208dad6b90c3963.tar.bz2
gentoo-2-2b4b02ed99892de69e78a7dc1208dad6b90c3963.zip
Version bump.
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog8
-rw-r--r--dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch38
-rw-r--r--dev-libs/libxslt/libxslt-1.1.26.ebuild46
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index ea857af6ff36..9b61f99147a4 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxslt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.190 2009/05/31 23:10:10 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.191 2009/10/07 14:39:51 ssuominen Exp $
+
+*libxslt-1.1.26 (07 Oct 2009)
+
+ 07 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +libxslt-1.1.26.ebuild, +files/libxslt.m4-libxslt-1.1.26.patch:
+ Version bump.
31 May 2009; Gilles Dartiguelongue <eva@gentoo.org>
libxslt-1.1.24-r1.ebuild:
diff --git a/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch b/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch
new file mode 100644
index 000000000000..d6aaae4e9df0
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch
@@ -0,0 +1,38 @@
+diff -ur libxslt-1.1.26.orig/libxslt.m4 libxslt-1.1.26/libxslt.m4
+--- libxslt-1.1.26.orig/libxslt.m4 2009-05-12 09:29:34.000000000 +0300
++++ libxslt-1.1.26/libxslt.m4 2009-10-07 17:03:04.000000000 +0300
+@@ -52,8 +52,10 @@
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_xslttest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
++ ac_save_CXXFLAGS="$CXXFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$XSLT_LIBS $LIBS"
+ dnl
+ dnl Now check if the installed libxslt is sufficiently new.
+@@ -138,6 +140,7 @@
+ }
+ ],, no_xslt=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+@@ -158,6 +161,7 @@
+ else
+ echo "*** Could not run libxslt test program, checking why..."
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$LIBS $XSLT_LIBS"
+ AC_TRY_LINK([
+ #include <libxslt/xslt.h>
+@@ -177,6 +181,7 @@
+ echo "*** or that you have moved LIBXSLT since it was installed. In the latter case, you"
+ echo "*** may want to edit the xslt-config script: $XSLT_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
diff --git a/dev-libs/libxslt/libxslt-1.1.26.ebuild b/dev-libs/libxslt/libxslt-1.1.26.ebuild
new file mode 100644
index 000000000000..a276ab078a99
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.26.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.26.ebuild,v 1.1 2009/10/07 14:39:51 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="crypt debug python"
+
+RDEPEND=">=dev-libs/libxml2-2.6.27
+ crypt? ( >=dev-libs/libgcrypt-1.1.42 )
+ python? ( >=dev-lang/python-2.5 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/libxslt.m4-${P}.patch \
+ "${FILESDIR}"/${PN}-1.1.23-parallel-install.patch
+ eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --with-html-dir=/usr/share/doc/${PF} \
+ --with-html-subdir=html \
+ $(use_with crypt crypto) \
+ $(use_with python) \
+ $(use_with debug) \
+ $(use_with debug mem-debug)
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ mv -vf "${D}"/usr/share/doc/${PN}-python-${PV} \
+ "${D}"/usr/share/doc/${PF}/python
+ dodoc AUTHORS ChangeLog FEATURES NEWS README TODO || die
+}