summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-09-06 03:09:06 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-09-06 03:09:06 +0000
commita78b8a141a349f3b0d9de26ce550cd48c46b3d1e (patch)
tree4a3cbd15b7416ab00dc6947c65686abee105cadd /dev-libs/libxslt
parentnew version (diff)
downloadgentoo-2-a78b8a141a349f3b0d9de26ce550cd48c46b3d1e.tar.gz
gentoo-2-a78b8a141a349f3b0d9de26ce550cd48c46b3d1e.tar.bz2
gentoo-2-a78b8a141a349f3b0d9de26ce550cd48c46b3d1e.zip
new version and a patch to make it adhere to sandbox with DESTDIR and python
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/ChangeLog7
-rw-r--r--dev-libs/libxslt/files/Makefile-py.patch18
-rw-r--r--dev-libs/libxslt/files/digest-libxslt-1.0.201
-rw-r--r--dev-libs/libxslt/libxslt-1.0.20.ebuild43
4 files changed, 68 insertions, 1 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 2a5e8838a73c..630aacfabbf0 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.8 2002/08/02 03:26:32 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.9 2002/09/06 03:09:06 spider Exp $
+
+*libxslt-1.0.20 (06 Sep 2002)
+ 06 Sep 2002; Spider <spider@gentoo.org> libxslt-1.0.20.ebuild :
+ new version
+ had to patch the python/Makefile to make it adhere to DESTDIR
*libxslt-1.0.19 (07 Jul 2002)
01 Aug 2002; Mark Guertin <gerk@gentoo.org> libxml2-2.4.23.ebuild :
diff --git a/dev-libs/libxslt/files/Makefile-py.patch b/dev-libs/libxslt/files/Makefile-py.patch
new file mode 100644
index 000000000000..c2af3d102b72
--- /dev/null
+++ b/dev-libs/libxslt/files/Makefile-py.patch
@@ -0,0 +1,18 @@
+--- python/Makefile.old Fri Sep 6 04:51:27 2002
++++ python/Makefile Fri Sep 6 04:52:06 2002
+@@ -479,11 +479,11 @@
+ cat $(srcdir)/libxsl.py libxsltclass.py > libxslt.py
+
+ install-data-local:
+- $(mkinstalldirs) $(libdir)/python${PYTHON_VERSION}/site-packages
+- /bin/install -c -m 0644 libxslt.py $(libdir)/python${PYTHON_VERSION}/site-packages
+- $(mkinstalldirs) $(DOCS_DIR)
++ $(mkinstalldirs) $(DESTDIR)/$(libdir)/python${PYTHON_VERSION}/site-packages
++ /bin/install -c -m 0644 libxslt.py $(DESTDIR)/$(libdir)/python${PYTHON_VERSION}/site-packages
++ $(mkinstalldirs) $(DESTDIR)/$(DOCS_DIR)
+ @(for doc in $(DOCS) ; \
+- do /bin/install -c -m 0644 $$doc $(DOCS_DIR) ; done)
++ do /bin/install -c -m 0644 $$doc $(DESTDIR)/$(DOCS_DIR) ; done)
+
+ $(GENERATED): gen_prog
+
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.0.20 b/dev-libs/libxslt/files/digest-libxslt-1.0.20
new file mode 100644
index 000000000000..4ff532127e61
--- /dev/null
+++ b/dev-libs/libxslt/files/digest-libxslt-1.0.20
@@ -0,0 +1 @@
+MD5 625fe50ff1c41f88f48b0f219f2022a1 libxslt-1.0.20.tar.bz2 1489697
diff --git a/dev-libs/libxslt/libxslt-1.0.20.ebuild b/dev-libs/libxslt/libxslt-1.0.20.ebuild
new file mode 100644
index 000000000000..f81225ad0278
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.0.20.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.20.ebuild,v 1.1 2002/09/06 03:09:06 spider Exp $
+
+inherit libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XSLT libraries and tools"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+RDEPEND=">=dev-libs/libxml2-2.4.24"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ econf || die
+ #libxslt-1.0.19 didn't like parallel make; test a good deal before re-enabling
+ #(drobbins, 24 Jul 2002)
+ patch -p0 < ${FILESDIR}/Makefile-py.patch
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}